Cannot establish remote connection (error 31520)

I have the same issue…
please fix it @wd.com

Same problem here, very annoying. I have sent a message to WD support to inform about the problem.

I have the same problem. WD should fix the problem. If anybody can explain step by step how to fix this problem. Thank you in advance…

I was able to solve the problem after contacting WD support and doing some tests. In my case, the solution was this:

1- Open the TCP ports 80 and 443 of my router for my My Book Live IP address.
2- Switch to manual remote connection in the setup options of my My Book Live.
3- Introduce the ports 80 and 443 in the setup of the manual remote connection.

After applying this configuration, I can access again to my My Book Live using My Cloud app and a mobile data connection.

Hi guys. The following actions helped me. I entered the application on my phone -> Settings -> Advanced settings (Verify device connectivity) -> Removed the switch from my device. Rebooted the application. From a home network, everything works fine. Write if this helped you.

1 Like

This one worked for me too, thanks!

I contacted WD and escalate the issue with their customer relations department, where their CORP team make their high level TECH providing me a solution similar as @vsokoyvg.

Personally I dont like opening ports on my router so here is the solution provided to me by Linksys with an updated Certificate file.

In order to do all steps I downloaded and used WinSCP (https://winscp.net/eng/download.php), which allowed me to connect to my book live through SSH from my windows 10, transfer the new Cert, rename old and set the properties mentioned on it.

  • enable SSH
  • go to /usr/local/orion/openvpnclient
  • rename ca.crt to ca.crt.old
  • copy the attached ca.crt.txt and rename to ca.crt
  • chmod 774 ca.crt
  • Set your Remote Access as Automatic on your MyBookLive daskboard and Reboot the My Book Live from the dashboard.
  • You can verify proper operation of the cert by checking the log file using this command cat /var/log/openvpn.out

Hope it helps and remember to remove any port forwarding if you enabled it and enable UPNP.

ca.crt.txt (1.3 KB)

2 Likes

Hi.
I followed the steps you suggested.
Here it is the message in /var/log/openvpn:

Options error: --nobind doesn’t make sense unless used with --remote
Use --help for more information.

What is going wrong?

Thanks

The last step needs to be done on the terminal.

cat /var/log/openvpn.out

Its a log file that will tell you if the process went correctly.
At this point you should be able to connect remotely to the MBL without the port forwarding and as Automatic option on the dashboard.

Thanks you for your reply.
The result is the same

MyBookLiveDuo:~# cat /var/log/openvpn.out
Options error: --nobind doesn’t make sense unless used with --remote
Use --help for more information.
MyBookLiveDuo:~#

The error 31520 is always present.

Hi

Thanks so much for all your work on this.

I have followed your steps carefully. It looks as if your new certificate file has been uploaded correctly and, as far as I know the chmod 774 ca.crt command has completed correctly (there is no error message anyway)

On the final step I also get the error message with the last command (i.e. Options error: --nobind doesn’t make sense unless used with --remote
Use --help for more information)

I also still get the error 31520 and a failed internet connection.

I guess I must be doing something wrong but I can’t see what… Any help much appreciated!

We have a few of these drives and it would be really helpful to get them working online again…

Hi,

I didnt get that error when I checked on the openvpn.out.

Did you reboot your MBL before checking on the openvpn? , from the Dashboard or taking the power of NOT from the console.

Im still in communication with WD Support, I will ask about this error.

WD Community,

The following article has been made available for My Book Live and My Book Live Duo.

How to Update the Security Certificate on a My Book Live or Duo (Remote Access Error 31520)

Answer ID 29501

1 Like

Yes, I have rebooted nas many times from the dashboard. And also deactivated and activated remote access many times.
Let me know if wd support tell you something.

Thank you

@robbyar, @Tabu

I was able to reproduce the error when:

  • I disabled UPnP in the router
  • And uncheck the option for software/users configure UPnP.

Linksys example attached.

I have a double nat in my LAN.
One router (internal) has upnp enabled. The other one (external) has upnp disabled.
This configuration worked until error 31520 appeared few days ago.
Have I to enable upnp on the second router?

Enabled upnp also on second router and connection works.
No more error 31520! :slightly_smiling_face:

Thank you very much @RamPc

Hi everyone. Has this issue been solved? I have exactly the samer issue. I went into the settings and disabled and reenabled remote connection but got the error message “Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520)” but the network tab said I was connected fine and I can access my documentrs on mybooklive through the ethernet connection to my PC. It is remote access which does not work.

has anyone found a solution. I am running the diagnostic test but without much hope!
Thanks everyone

but thanks for pointing me to this. For IT ignorant like me it’s mind blowingly complicated.

Is there a simple solution? Maybe a patch file to download? I am unable to understand the technical solutions. All I want is to access my wd drive on my tablet and phone. (pc works as it is cabled). Otherwise will bin my drive and get a new drive - definitely NOT another WD drive as they dont seen to care.

Update - All of a sudden all the android apps are connecting ok to the drive again!!

1 Like