Cannot connect to MyCloud

Hi, after recent firmware update (probably) I cannot connect to the drive from my job using WD My Cloud app any more. Previously it worked ok. What am I doing wrong?


Did you try to remove the device from the app and then add it back?

Just tried to do it but have got ‘No devices found’ error.


Can you add back the device as a new wdmycloud login device?

 For what it’s worth. My connection on a mobile network is very random. Sometimes it will connect, others it will not connect for fairly long periods.


I’ve been having the same “Unabl to access device. (0)” problem also after undating firmware.

And I tried to delete device, get new Access Code, but still getting the same error message when trying to access remotely.

Please help.


This was probably my fault as it turned out I was using different email addresses to log in to WD server from WD Cloud app at work and another email was configured in the dashboard. When I changed it on the drive it now works correctly.

However I am not sure how I was able to log in to drive remotely before upgrading firmware? :slight_smile:


Note that after the firmware upgrade fixing the Heartbleed issue, I had to reconnect to the device already setup on various mobile devices.