Cannot Access EX2

I just recently switched to a MAC, and cannot access the EX4.  I tried the reset button on the back; however, the units is retaining all of the old settings, and refusing me access to the unit.

What else can I do, shy of throwing it against the wall?



H tommcelvy,

have you tried the “5 seconds” or the “40seconds” reset versions ?

Someone had succesfully restored his EX2 using the MyCloud reset procedure (below).

Good luck.

“The Reset button may also be used to perform a System Restore on the device. At the same time as the power is plugged to the My Cloud device, pressing the Reset button and holding it for about 40 seconds, will make the device to go through a System Restore instead of a Reset. This System Restore will not cause data loss”

I was unaware of the 40-second solution, so I grabbed the drive and tried that.  It did the trick!
I was able to access the unit with the default info, and get everything rolling again, without having to get the partitions dropped.

Many thanks!