Locked out of admin - Help!?

Hi, apologising in advance as I am pretty new to this and so not sure what to do. Think I’ve made a silly mistake and unsure how to fix it. 

I tried to change my admin username and password on my EX2, once I made the change it forceably logged me out and since then I haven’t been able to log back into the dashboard again - I keep getting “username password not recognised” errorr message. I have tried (what I thought were) the new login and password, I have also tried the 5 second reset - which I was expecting to reset the password and login details, but this doesn’t seem to have made any difference. At my whits end…can anybody help? 

Would obviously like to be able to fix this without loss of data, but wouldn’t be the end of the world if I had to reload the data, nothing would be lost as I have it held elsewhere at the moment. 

Many thanks in advance

Welcome to the Community.

Try holding the reset switch for at least 10 seconds. The device will reboot and clear the default admin password. If this does not work then it’s possible for the reset switch not to be working properly. If so, you may need to contact WD’s tech support. You can do so either by phone or E-mail.

To Contact WD for Technical Support

Support by Country


1 Like

Hi. Something that worked in the end. I did a full reboot, unplug, hold reset button, plug back in whilst pressing reset. Keep pressing reset for 40 secs. This eventually wiped the settings and reset the password.

Will think twice before trying to set a password again though.

Thanks for the help

Did you use an ‘Uppercase’ letter as the first letter of the new username? I made that mistake. All it does is nicely change it to lowercase without telling you (linux can’t cope with uppercase first letters in usernames). So basically if you did use uppercase, try the username/password with a lowercase first letter.

p.s. WD, how hard is it to add a simple warning saying ‘you cannot use an upper case letter as the first letter of a username’? Seriously…

1 Like

Yes I did use upper case, that would probably explain it. Scared of changing this again just in case i have to go through the reset again.

Definitely worth knowing, thanks.

This issue was reported to WD technical service long time ago. But unfortunately WD ignores it. A corresponding idea-thread, suggesting a warning or something similar, is existing (but also ignored by WD).


I’ve had the same issue with my EX4100 which is a matter of days old and about to be returned.  Through a lot of trial and error, I’ve managed to get back into Dashboard (as though setting the NAS up for the first time) by doing a 40 second power on reset.  Note the manual talks of either a 6 second power on reset, or a 40 second power off reset.  I just stuck my trusty iPhone SIM tray (paperclip) into the reset buttong and held it there for a good 40 seconds - it appeared to go through a double reset but not sure.  I then tried http://wdmycloudEX4100.local and initially greeted with the same log-in but on refresh of the webpage (Safari) it came up with a Username: Admin and Password: (no password set).  Bingo.  Lets see how long this fix lasts.