Can’t access to via android app with my account

good morning,
I have a 4tb my cloud ex 2 ultra. everything fine until last week when I changed my mobile, now I’m having the following problem: on website I can access and reach my ex 2 ultra and manage my files, instead on the mobile app when I try to connect to MyCloud service the system answer that the mail ot the pwd are wrong.
The mobile is a xiaomy redmi note 9 pro. I tried to reset the pwd, reconnect the cloud, type the pwd and mail many times and check for case sensitivity on the mail adress but none worked.


I recognized the same problem since 08/21

After some research i came across the SSL-Security-Certificate which isnt valid anymore since the 08/21.

Using your webbroser you will be able to accept the invalid certificate and use the non-secure way to access your data.

The APP will only work again if WD will renew their SSL-certificate.

1 Like

Thank you for your reply. I’ve already accepted the certificate on the website.
So if I’ve understood, I can only wait for WD to renew its certificate to use the app. Isn’t it?

Thats the only solution i figured out…

Go forward and open up a supportticket for this problem… the more supporttickets the better, perhaps we can force WD to react.

Add my name to this list. :slight_smile:

I have had two mycloud devices lose access to the OS3 app. Full access to the website.

Same here Android 10. No access via app, only web access after accepting certificate, shame it was working good

I have just purchase an EX2 ultra - i am having same issue - about to box it up and send it back to Amazon

Give it a day or two. . .this broke just yesterday; it used to work pretty well.

1 Like

Let’s give it a few days. Only had my box about 4weeks and it was working great on Android 10 to be fair after disabling a setting on my Virgin Hub3 router.

LAN is fine and web via my cloud.

Be good to get it back up and running on the app, so just going to sit back and not mess about with any settings yet, albeit I’ve got NAS & Router working config back ups

i just bought it and the same bug

Same here. Since 08/21 WD Sync, Android App and standard web access don’t work remotely.

The only way is to accept the invalid certificate on web browser.

(Obv in local everything is ok).

I hope that WD will fix this soon.

Same here, please fix it ASAP WD!

same issue here for some days. And also is showing a certificate out of date.

No good news, still no access. Does Someone at WD read theese issues?
More than a week …

really frustating. Would be nice to at least get some feedback that something is wrong and is will be corrected.

1 Like

They should have renewed the certificate: WD Sync restart working and browser access doesn’t require to accept the invalid certificate.

But still nothing with Android, My Cloud OS 3 app still says “invalid username or password”.

Anyone has the same problem?

Yes still the same issue here…

1 Like

Here I am! No way to access via app.

1 Like

All working again via the app remotely.
Happy days

Ok even for me.
Thanks folks