I can't access to my Wd MyCloud

I can’t access to my Wd Mycloud at moment. But I can access to mycloud in the
same LAN band, but on https://files.mycloud.com/ or App on mobil phone can’t. What happen on my Wd Mycloud?

from 21st of Aug there is some issue.
we all are facing that issue.
Already rise a ticket to support team but they did not reply it

thank you for your opinion.

I’ve got exactly the same issue…


It appears to be a problem with the ssl security certificate used by WD which expired on 8/20/2020. When using MyCloud.com, if one accepts (at least with a web browser on a computer) the expired certificate one can access the My Cloud device after reloading the page (at least I can).

Same issue here with a Galaxy S10+. Spent a whole day with WD support and they advised it is a device specific issue and I should use a different device. I would prefer not to do so and have WD fix the issue.

I have tried 3 different models of device. None of them worked. Keep raising those support tickets. Eventually WD should realize what is blatantly obvious to the rest of us.

I keep getting the same error message.

“Something went wrong, please check that you have an active internet connection and try again”

Everything on my part is fine and I would try to unplug my cloud, but I’m so afraid that I’ll ruin my cloud. I have all my favorite pictures and music saved to it also a lot of work/schools files that are way too important to lose.

I tried unplugging my MC. It made no difference, and didnt destroy my data.

Bonjour, meme symptôme depuis hier, impossible d’accéder au cloud via donnée “Une erreur s’est produite, veuillez vérifier que vous disposez d’une connexion Internet active et réessayer”, ok via de wifi en local l’appareil est encore attaché au compte my cloud.com.
si l’appareil est détaché du compte mycloud.com tout est HS car ensuite l’ampli refuse la connection au compte en wfi et donnée. impossible également j’ajouter un appareil via un code. ok via interface web après acceptation nouveau certificats.

le probleme vient des serveur de wd car tout fonctionné il y a 1 semaine.

I have been chatting with WD:

Paul J: Specifically, i cannot log in to the mycloud android app. lots of people on the community chat are having the same problem. Are you aware of the issue? When will it be fixed?
Samual B: Yes, I was referring to that issue only - Our team is working on the new update that would fix every possible issue - however i believe the access from the mycloud.com web applicarion should be live
Samual B: And the local access aswell
Samual B: this Could take up 4-5 Business days