Can not connect to WD My Cloud Ahhhhhhhh

Hi all

Problem

Can not connect to WD My Cloud via https://files.mycloud.com/login.php

This connection issue can be replicated on Linux , Windows and Mac OS.
This issue appears to have only developed after a recent firmware update.
When accessing the UI WD device via URL IP of WD device. Then navigating to the Cloud Access icon>user. I can see there is a connection error message:

Failed
Cannot establish remote access connection. Make sure you are connected to the Internet.

Attempted solutions:

I have run diagnostics quick and full test with no issues reported. I have rebooted the WD device via [ UI ]. I have shut the device down via UI.

I can ping to WD device IP and there is a connection and no packets lost.
In an attempt to recover data I thought I would try to SSH or FTP ( both enabled in WD UI ) .

I have however hit a problem here. I am using the login credentials of root and welc0me
I have tried to SSH via terminal and had login issues giving error message:

z@192.16… etc password:
Permission denied, please try again.

I tried as root user and I did get this message:

You are required to change your password immediately (root enforced) :thinking: :thinking: :face_with_hand_over_mouth: :face_vomiting:
Linux WDMyCloud 3.2.26 #1 SMP Thu Jul 9 11:14:15 PDT 2015 wd-2.4-rel armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Changing password for root.

:sob:

I have read since that SSH is not supported and sshd is now the way to go. This SSH FTP side of things is not something I am very familiar with.

That said using the sshd IP server etc I got this message:

sshd re-exec requires execution with an absolute path
:scream: :scream: :scream: :scream: :scream:

Before I continue stumbling around for threads and solutions and break things further. Any advise on how I might be able to SSH or FTP into the server given there seems to be some type of permission or connection issue going on. Data recovery is the main end goal here.

Any tips on threads or things to try would be great !

Thanks all

:exploding_head:

@Ohsnap This doesn’t sound like a My Cloud Home. Is that what your have, or is it a WD My Cloud? WDMyCloudImage

What device do you own?

Click on, tap or activate image to enlarge it.

Hi

Hmm. :thinking:The device I have is a WDMyCloud . Any advise on submitting my thread to the correct section of this forum ?

Thanks

p.s I will note that an attempt I just made using Filezilla to access WD server was meet with message:
Insecure server, it does not support FTP over TLS.

SOLVED :hugs:

SOLUTION:

One of the following changes made via UI has seemed to have resolved access to the WD device.

  1. NTP Service was turned off
  2. Cloud Access > Remote Access was tuned off and turned back on and content data base was rebuilt

This has seemed to have resolved to access via https://files.mycloud.com/login.php I have not re - attempted SSH or FTP.

Cheers all !

1 Like

I talked to a Level 2 tech today 3/13/20 and he said the web site was down and they were working on it and to check in a couple days…

2 Likes

Just to clarify. You spoke to a level 2 tech that works for WD about the initial post I made. This tech person said the website is down and to check back in a couple of days ? :rofl:
Love it. lol

The issue did actually happen again today and took same steps to resolve it as I posted as solution. But maybe Ill just wait a couple of days :laughing:

A couple of days :rofl: :joy:

how much do you want to bet that the device never lost contact with WD though :blush:

I am having the same problem I cant access my cloud from home it says device offline … can you tell me what to do to fix this please as I dont understand all the letters and things sorry :frowning: but you seem to know more than they do I am sick of their email replies saying its down and they are working on it I need to get access to my work as Im working from home (p.s. I have done this many times before and it worked but I now have windows ten)

Same story, cannot access from Internet, access is fine when inside the network.
Told by WD Support that they are working on it. It’s been a week and still nothing.
Subnet and gateway settings have not changed.