Can Not Connect 7 Yr Old WDMyCloud to Home WiFi

I recently moved and my 7 year old WDMyCloud is connected to my router and has a solid blue light on front - but when I go into my Windows 10 Settings it shows up as Not Connected. The Device worked fine until I recently moved into a new house. I’m not sure if the software is OS3 or OS5. I still have the WD software in my Program Files on my pc. Any advice as to how to connect to my home wifi would be much appreciated. BR, Bucky


I posted this on your other topic about this problem.

If the front light is blue and you are connected to your router what are the rear LED lights doing, if anything?

Are you able to get to the Dashboard? You can find what firmware is on your device by looking at the Dashboard.

On your router can you see the address for your WDMYCLOUD?

If your device has a blue light on the front and the rear LEDs show you have a connection, try this, and see what happens //WDMYCLOUD or the name of your device. See if using that as the address opens it.

Front light is blue. On back of device there is a solid light which is green. Here is a photo below. In my Program Files>Western Digiral there is a folder labeled WD SmartWare which has many files - one of which is WDSmartWare. When is click on this file it opens what I believe is the Dashboard (at the top it has tabs labeled Home, Backup, Retrieve, Settings and Help). It also identifies the software as WD SmartWare Version I hope this helps.

What does “when I go into my Windows 10 Settings it shows up as Not Connected” mean? Is there an error message? Do you even see the My Cloud icon in Windows File Explorer Network section?

Can you access the My Cloud Dashboard?

How to Access the My Cloud OS 3 Dashboard

An example of what the My Cloud Dashboard looks like (the icon for your device will be different in the Dashboard):

Quite often people who move their My Cloud from one broadband provider to another or to a new residence find they need to perform a 4 second reset which resets the DHCP setting so it obtains the device’s IP address from the local network router/gateway.

Pin Reset and System Only Restore a My Cloud OS 3

Having a similar issue. Let me preface this by saying all of my knowledge is acquired via this forum, youtube, and google searches so hopefully what I’m describing makes sense.

Five days ago I successfully recovered my data via these steps and I was able to access via file explorer. Since then, MyCloud has disappeared. Nothing changed within that timeframe but the IP address no longer works and when I log in to my router, it’s not even listed. I also tried the arp -a command. Again, nothing.

I’m worried if I disconnect the power supply, I’ll be back to where I started. At this point, I’d prefer to just extract all of my data and trash the MyCloud.

What color is the front LED? Blue or something else? Is it flashing or a steady color?
Have you tried replacing the ethernet cable between the My Cloud and the router/gateway?
Have you tried connecting the My Cloud to a different network port on the router?
Has anything else changed since the last time you were able to access the My Cloud post recovering your data by the method you posted.