Can i install apps in WD my Cloud 4 TB?

Can i install apps in WD my Cloud 4 TB ? if yes then please tell me step by step procedure. I have gone through so may discussions but not able to draw conclusion!
someone please help.

If you have a second generation v2.x firmware My Cloud, yes you can modify the firmware using SSH to install and run third party apps.

If you have a first gen v4.x firmware My Cloud, you cannot use the process used for the 2nd gen single bay My Cloud to add additional apps. The first gen firmware is different than the second gen firmware. And no one cannot upgrade a first gen to second gen firmware.

Use the forum search feature to find the few apps that can be installed to the first gen My Clouds.

For example see the following thread for various apps that may work on the first gen v4.x single bay My Cloud units.

I have my device with Gen1 having v4 firmware. Unfortunately i have tried the steps suggested in the post and tried a few commands using SSH.
Now i am not able to access Dashboard of my device but yes i am able to access it with smartware software and data is also accessible.

Please guide me how to get the dashboard.

Without knowing exactly what steps you have performed its difficult to give solid advice. Depending on what changes one made via SSH it may be possible to roll those changes back by reversing what ever process (for example removing any changes made) one used in the first place.

If you have corrupted your firmware to the point where the My Cloud Dashboard cannot be accessed using the normal methods then one may have to backup their data on the My Cloud and perform one of the various unbrick processes to try and restore the firmware to it’s unmodified status. User Fox_Exe has one popular method of unbricking a first gen My Cloud.

The main Fox_exe repositories for multiple My Cloud models can be found here:

First gen directions:
The img files needed for the first gen Fox directions can be found in the WDMyCloud-Gen1/Backups folder in the main Fox_exe respoitory link above.

Thanks Bennor, The Fox_exe repository was the solution to all of my problems. I have followed step by step procedure mentioned there and the same firmware and other related files along with the set of commands was so helpful and easy like magic.

Thanks a lot for helping me out from the situation. I have also tried installing SSD in to same NAS and it was a great success. By putting SSD in to NAS it was so fast and storing and retrieving the data. The only problem with SSD is the higher cost.

Finally, thanks a lot. I am happy that i could do it with your help.