Brand new My Book, "Too many bad sectors"

Just bought a brand new 6TB My Book. The drivers installed and Device Manager says it is fine. It wouldn’t show up in Explorer. Went into Disk Management and it says it’s Online but not Initialized. Try to Initialize and it says that “The device is not ready”; eventually, the “Initialize drive” options gets greyed out. Convert to GPT also returns “The device is not ready” sometimes; other times it says the drive is not big enough. I tried WD Drive utilities, but it wouldn’t even acknowledge that the drive was there.

I went to the store and exchanged the drive.

Got the new drive home and same situation.
Tried diskpart:

  • Cleaned the drive
  • listed attributes, noticed (sometimes) it said Read-only was enabled so I tried clearing it and it said it was unsuccessful.
  • Tried Convert to GPT, it said the object information was not up to date and to rescan
  • Rescanned, did everything with same results.
  • Different computer same results.
  • Went into safe mode with Cmd Prompt, same results.

Found “WD Data LifeGuard Diagnostics”, ran it, and it failed every single test with “Too many bad sectors”. I’m assuming this would have been the result with the first drive also, since it exhibited the exact same symptoms. Two brand new drives.

Any advice would be appreciated. I’ve been extremely luck and have never had to RMA any computer component before. What is the process? Do they send a container with paid shipping? If they don’t, I’m probably just returning it to the store.

Hello,

Based on the information you have provided I believe this drive is defective, as well as the previous one.
It it very hard but no impossible to get 2 damaged drives. I recommend you ask the store to test the next drive before you go home.
WD can also replace your drive. Click on the link below for more information.

In your case, I would take it back to the store and let them know that this drive and the one before were . It will keep you from having to wait for a new one, and the store can test it as well to see if there is another issue there. G/L

Two drives from two different stores with the same symptoms?