Blue LED light not showing on WD cloud

Thanks…I gave up and had the box replaced, but will bear this in mind if it should fail again!

1 Like

My blue led has been dead for years, and it’s never bothered me. But I thought I’d give your workaround a go. Works nicely, thanks.

To get the LED state to refresh, I unplugged the network cable until the drive realised it was missing, and then plugged it back in. I now have a green LED.

1 Like

I spotted it sleeping the other day; nice, slowly throbbing green LED…

1 Like

I’d like to start out with THANKS!

  • THANKS to the WD Community at large. Your postings allowed me to realize that the failure of the blue LED is a common problem.

  • Special THANKS to naseriax for providing a software work-around for the failure of the blue LED.

I used solution 2 from naseriax to change all the “blue” references to “green”. Everything is working as expected. Very nice!

For those that may be considering doing the same, I offer the following:

  • Make a backup of ledConfig.sh prior to making any changes. That way, if you mess it up, you have a clean backup to recover.

  • As instructed, change all “blue” with “green” on the LED_NORMAL_COLOR line. To fully implement the change to green, make the same changes for LED_ERR_COLOR and LED_WARN_COLOR. The change to Warn Color is needed to get the green pulse when the drive is in sleep mode.

Good luck!

2 Likes

Glad being helpful:)

Hello DennisKB
Thankyou so much for this led fix,only one thing, I cannot find the ledConfig.sh file anywhere?
I have the WD Mycloud 3TB is there something I am missing here,or am I just having a brain freeze?
Thankyou,could you please help me out here? Much appreciated.

1 Like

Thanking you 2000% changed blues to green and set LED on in UI works well now I can tel that WDMyCloud drive is On :grinning:

PS turns SSH back off after use in UI to be extra safe.

1 Like

March 28, 2020
I reactivated my WD MyCloud (3 TB, gen1 “04”) after disconnecting 18 months ago (upgraded to Synology).
Recommend Upgrade: Firmware Release 04.05.00-342 (09/04/2019)
This NAS appliance actual works better now, than it did in 2017.

naserix solution, plus the DennisKB additions, resolved the dim Blue LED on MyCloud.
Now have a nice bright Green LED.
When using SSH with “root”, remember that password is: “welc0me”

gb

1 Like

Hi,
The file is located in below path, just SSH to your mycloud and you will find it here:

/usr/local/sbin/ledConfig.sh

Just a quick note, if you update your firmware, the ledconfig file will be re-written and you need to execute the procedure again to have your Green Led color back.

Have fun and stay safe!

Merci, cela fait plusieurs années que je cherchais un solution pour allumer de nouveau la LED.
Merci

1 Like

is there anyone who could help me out fixing my power light “blue light”
ideally a step by step indtructions iv a mac and all the walk throughs seem to be on a windows machine

i have a 4tb my cloud

cheers
dave

1:Login to your mycloud webUI entering its IP address in a browser
2:Go to setting> Network and turn on the SSH. default password will be welc0me
3:Use a simple terminal emulator app like putty to ssh to your myCloud using its IP address.
4:You should see similar prompt after a successful login: WDMyCloud:~#
5:Enter below 3 commands, you should get no output or error.

WDMyCloud:~# cp /usr/local/sbin/ledConfig.sh /usr/local/sbin/ledConfig.sh.orig
WDMyCloud:~# sed -i "s/blue/green/g" /usr/local/sbin/ledConfig.sh
WDMyCloud:~# exit

6:To test it, unplug the network cable until it starts to blink, then connect it back (Thanks [cpt_paranoia]).The green led will turn on.
7: Go back to webUI and disable SSH for security purposes.
note: Remember after every firmware upgrade, you need to redo this procedure.

2 Likes

Thankyou for the updated tutorial it worked 1st time

Did anyone else get prompted to change the root password from welc0me to another password

Cheers
Dave

That is expected behavior when one enables SSH. The user should be prompted to change the default password upon first login to the My Cloud using SSH.

For example, from the following WD Knowledgebase article:

Access Denied when SSH Login to a My Cloud
https://support-en.wd.com/app/answers/detail/a_id/24926/

Important:

The My Cloud (Single Bay) with firmware 04.xx.xx-xxx force the change of the default password upon first connection attempt…

Thankyou

I have My Cloud Mirror 4 TB, and the LED for Volume 1 is quite dead, and I would like to try your solution. It uses firmware version 2.12.127, and when I ssh into the My Cloud it says:

BusyBox v.1.20.2 (2014-10-30) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

The built-in commands listed do not include ‘cp’ or ‘sed’, and i am a bit wary about experimenting as I do not want to brick the My Cloud device. How could I proceed without too much risk?

Well, Since the shell and Machine are different, I cant say much unfortunately.
But you can try:
After ssh enter commands:

bash
which cp
which sed

Basically they are safe commands.
If you get the path for 2nd and 3rd commands in the output like /usr/bin/sed (for example), it means you are in a good environment.

Then you can use below safe command to see if the ledconfig file is in the same path as myCloud or not:
ls -la /usr/local/sbin/ledConfig.sh
If you get the file information, then you may use the same procedure (with your own risk since I didnt test it :wink: )

I have tried your latest advice, and it has brought me almost to success, but not quite. Here is a report:

  • After the ‘bash’ command, ‘cp’ and 'sed* commands became available ('which* was not accepted, however).
  • I ran your cp command and then cd’ed to /usr/local/sbin and used ‘ls’ to list the files there. I now had both ledConfig.sh and ledConfig.sh.original, so that command worked.
  • I then ran the ‘sed’ command without issue, exit’ed the bash shell and then exit’ed busybox.
  • I then stopped the My Cloud Mirror and started it again. The led lights were still blue, and middle one was still dead, so something had not worked.
  • ssh’ed to the MyCloud box again, started the bash shell, and checked whether nano was available. I wasn’t, but vi was there.
  • I ran the command vi /usr/local/sbin/ledConfig.sh and the file opened, but only as ‘Readonly’. There was one “blue” left in LED_NORMAL_COLOR and one in LED_WARN_COLOR. I changed these and tried to force saving the changes with :wq!, but that did not work, so I had to leave without saving
  • Tried several more times to open ledConfig.sh, and also starting the command with ‘su’ and ‘sudo’, but it was always in Readonly mode.

So now I am stuck for the time being, but at least the My Cloud box is still working, and it was fun. Thank you for the advice!

Below I have uploaded a screenshot of the relevant part of ledConfig.sh as it is now.

This work, as advertised (LED now Green).
I would like to KNOW the Replacement multi-color LED to repair (hardware).
Since unit is Out of Warranty, and I have 35+ years of SMT bench experience — Skill not Issue — Just desire Proper Part (Save My Time Researching/Reverse Engineer).

gb