Bad Drive - How to Repair?


#1

I just got my EX2 Ultra, removed the 2x3TB drives from my old HTPC server and put them into the box and trying to setup.

I tried to switch the RAID to JBOD, it runs a test and says Disk A is BAD and that’s all. Pretty vague. Won’t let me continue. Been clicking all over and cannot find a way to do anything like a repair. I know in Windows there was always a check disk with a repair option.

In the old HTPC the drive never gave me any issues… hoping just a bad cluster or something that can be fixed.

Any ideas?


#2

So far, I piece back together my old HTPC system, and still had the old 250GB drive with Win7x64 on it that I yanked almost 2yrs ago, so, was able to boot right up into Windows.

Ran the scan/fix on the 3TB drive… had files and I think made it take longer to run. Found 1 bad cluster that it said was able to repair.

I then ran a format on the drive (NTSF-Quick) rebooted (just in case) and left the scan running again when I left this morning for work. When I get home I’ll see if any errors found, if not, I’ll see what the EX2 Ultra says.

Failing that, I’ll buy 2x3TB WD Red NAS drives, keep my Hitachi as a spare and not much I can do with the extra 3TB.

I’d like to upgrade from 3TB to 4-6TB each, but because I do mirror backups it would mean buying 4x4TB or 4x6TB drives… bit too costly for me at the moment. I’d recoup some money selling the 2 externals but not enough to warrant the upgrade.


#3

Put the drive in, and let me switch to JBOD and format and says health is OK.

NOW the scandisk option is un-greyed and I can click it in the My Cloud software. Kinda lame.

Thanks for the help? I guess?


#4

I am a fellow member with same problem, looks no one gona help anytime sooner so pining you.
I have 1TB WD drive already running.
I have second 320Blue WD having bad sector or Sector count pending checked via crystal disk info on Windows.
Works Well with windows.
But NAS is rejecting it saying it as BAD drive and not able to continue further.
Any ideas what should I be doing next?


#5

Ya… it’s odd software in that respect. You’d think if during setup you have issues, the software would be available.

I pulled my drive out, attached to a Windows PC and did the scan/repair and sorta worked. WD scanned it said it was fine, so I setup the JBOD and spent 20h per drive copying files over. Apparently plugging the external drive directly into the back of the WD is slower than transferring from PC to WD through ethernet, like 10mbps slower.

Got everything copied over, ran a scandisk because NOW the option was there and says GOOD.

Few days later, light is red and says BAD. If I do a quick check is says all drives are good, if I do the full check it says Disk1 is bad.

Found a store with WD 4TB Blue drives on really cheap, so, wasn’t planning on it but since my 3Tb drives were 90% full, I decided to buy 4x4TB drives and instead of using external drives for mirror backups, I grabbed a removable hard drive tray that goes into the PC and connects to SATAIII. Was a good sale, but now gotta format and copy everything over again.

Other issue I am having, and getting nowhere with, is constant buffering of video. I have an android box and while setting stuff up I’ve been on WiFi… I’ll be using ethernet eventually but was easier to get setup using WiFi for now. Ookla speed test has my WiFi speeds at 75-78Mbps up and down… yet, I’ll be watching a small 500mb 2000kbps MP4 video at 1080p and some days its fine, others it’s constantly stopping and buffering. Nothing else streaming, nothing downloading, 5’ from the router and >75Mbps… shouldn’t be buffering at all. Should be able to handle files double the bitrate at that speed.

Almost regret the “upgrade” to my setup. Would have been further ahead to have built a mini-PC and stick it in the corner. Idea behind the WD MyCloud was to save space, save power, and have something running 24/7 for others in the house to use. Ended up costing much more time/money than expected and performance decreased.