As Im Copying Files, Folder and Contents Disappear Minutes Later

Hi all,

First time poster, but reviewed a couple threads and couldnt find the same issue I’m experiencing. Has anyone else had an issue while copying files to a folder…and then the folder and contents disappearing?

All of my other folders, structures, and files seem to be in place.

Any suggestions? Folders dont seem to be hidden, files cannot be found in the trash. Im so confused.

Thanks for your time.

What computer/device are you using and the operating system?

If Windows 10, have you ever searched for the file or folder on your My Cloud using File Explorer? See image below. Click on, tap or activate image to enlarge it and see complete image.

If things are uploaded and the upload completes they don’t just disappear.

How many people are allowed to use your computers?

How are you copying files to the MyCloud? What tool are you using?

Are you using any sync tools?

Ive never seen this, thats why im concerned. Im the only user, there are 3 devices that link to my drive, two apple products and a windows 10 machine that I was using at the time to manually transfer files. None of the devices are set to automaticly sync. The folder was a couple 100 GBs and now cannot be found. Tried searching for folders and files that used to be located in the missing folder. Tried searching in both the windows file explorer and the file search bar foudn within the WD My Cloud software tool.

I dont think I accidentally clicked and dragged the folder in question off of the drive or pasted it somewhere else. And i dont think that I deleted the folder - I wouldve remembered seeing the window “do you want to permantly delete this folder and all of its contents?”

Any way to look at recently deleted folders if it was accidentally deleted?

Just copy pasting; No tools; No syncing. Window 10 machine was being used at the time of issue.

Are you saying they are missing from your My Cloud or your computer?

I have a first generation My Cloud and it does not have a trash bin.

What does the dashboard show for what is on your My Cloud? Here is an image of mine.

You may want to look at this information and read the User Manual for your generation of My Cloud.

https://support.wdc.com/product.aspx?ID=904&lang=en

Copy & paste using what? File Explorer?

Yes, file explorer on windows 10. Im starting to think that I lost awareness to the screen i was in and pressed crtl+d by mistake and somehow the window asking if i wanted to permanently delete this folder was accepted. I have no other explanation how it is no longer visible to me.

If the access rights on the files (on the file server) aren’t right, Windows won’t show the files. You can log in to MyCloud via SSH, then go to the directory in question, and do an ls -l to see if the files are there, and if the access rights look odd.

owner:group should be [username]:share
Permissions should be 775

looks just like my window. although it says i have 23 cloud devices - i guess ill have to look into this next. Soulds like ill need to get into the network settings and SSH into the drive, which i might have a friend help with since im a noob and dont want to screw anything up.

thanks for the info. ive SSH’d into a couple drives at work before but might need some help from a friend to navagate around to look at permissions. byw i understand ls command but what is the -l about?

ls -l list, using long format. Needed to see permissions and owner:group settings.

http://linuxcommand.org/lc3_man_pages/ls1.html