Another one that won't connect to the network

For the love of god :frowning:

I’ve tried everything;

-Automatic setup

-Manual setup

-Adding Google’s DNS server

-Disabling DHCP on my router

-Resetting my router to factory defaults 

Nothing works…  same IP/Gateway error. The network, of course, works just fine even now if I unplug my Hub and plug my Live in. Nothing I’ve read helped!

Any other ideas? Or should I return it? How disappointing… :frowning:


From what you’ve said I am assuming your network connection is “wired” and it works fine with the SMP plugged in, just not with the Hub.  I’ve had the same trouble seeing wired LAN at times and it is usually cleared up by going into the hub setup and doing a restart (not reset to factory, just re-start).  You may have to do it a couple of times before the hub will do a “network discovery” and find things again.  I think it happens because microsoft networks don’t run network discovery very often and I have best success connecting if everything on the network is running an hour or so before the hub.

Good luck,


Thanks for taking the time to write up, it sounds quite useful, though I did go through a few power cycles (both player and router). Would you say I have to re-set it to Automatic network setup before I try it?

Yes, leave the hub set for automatic network settings.  Also, if you use windows networks like most of us do, you should have proxy off, workgroup set to workgroup (unless you used a different name to set up your microsoft network).

Did you use the hub menus under set-up, network and check connection?  Did it find your network there?

Also, the hub doesn’t really power off fully unless you hold the off button for several seconds.  Just a push, the lights go off, but it is still in stand-by and can be seen and used on the LAN.  So powering off doesn’t do what a “set-up, restart” selection does.

Yeah, this didn’t work… I tried resetting the device and letting it discover the network several times now, no cookie.

Of course there is a hitch in the proposed solution: the device is not able to go on the network at all - no IP, no internet, no nothing, so discovering the home network wasn’t the problem per se.

Today I’m going to bring it to a friend’s house and try it on his own LAN, then take it in for a replacement.

What a shame… :frowning: Thanks for trying to help though!

Well, I just managed to get a cable long enough to connect the hub directly to the router, and it all worked first time. So maybe it’s a cabling problem, but then again why my WDTV Live works with the supposedly faulty wiring, as does my laptop?

LAN wiring can decieve you.  If one wire is open or shorted it can still run (although slowly since it is error correcting a lot).  If you are going to install more permanent wiring get a LAN cable tester and some good CAT6 wire.  And don’t staple it with metal staples, like a staple gun, use those wide plastic cable holders with one nail.  The little things can make a BIG difference in LAN performance.



Well, it’s a fresh CAT6 in-wall installation - rennovated my appartment two years ago… I’ll run some more testing, but it appears very strange that the WDTV Live should work with no issues at all, as do our laptopts (my wife actually uses the wire to connect to her work’s very particular VPN, and she prefers it over the wifi - and the router lies only two meters away), and the Hub cannot even see the router… 

You might want to buy a LAN wiring tester.  I’ve had this exact trouble due to wiring – some devices seem fine, some don’t work at all.

Am looking at LAN testers right now :smiley: Thanks for the suggestion!

Mine too…wireless connection shows DNS ERROR Nd Internet gets disconnected

Maybe something to do with the wifi adapter you use? Which one is it?