Alternative Firmware (Debian Jessie, Synology DSM6)

Oh no, I think I’ve completely bricked it. I’ve tried the USB stick route (formatted with FAT32) and the Mirror Gen 1 recovery boot/ files but nothing. A flashing blue light and continuous hdd power on. I’ve tried power cycling while holding down the reset for different durations.

I’ve then found some debricking instructions for the Mirror gen2 and followed the guide via Ubuntu Live to make a fresh install and add boot files directly to the drive. No luck.

Is there a Mirror Gen 1 debricking guide? Is it best to follow the My Cloud Gen 1 guide instead of the Mirror Gen 2 guide. Has my writing to mtdblock1 destroyed all chance of recovery?



So, how are you processing? I was hoping for a dsm fix or a new version :innocent:

I want to believe!

I stopped developing DSM because i sold all my WDMyCloud devices (I was simply tired of them).
So - no more updates from me.

All sources and information available on my website and GoogleDrive folder. So if someone want to continue my experiments - I provide all what need for this.

@Fox_exe, I am tired of mine too…

I’ve installed the Debian Jessie firmware and now Transmission downloads 3 times slower than before with standard firmaware.
Any ideas?

@Fox_exe Thanks for DSM, you have saved a lot of work for me as the WD OS is not strong enough. But I am facing an issue and I had to reset the device 3 times,

The Issue.
The Device boot properly and works good, but after 1 day(over nights) when i open the web login page i get a blank page witch some javscript error on debug console screenshot:

Other than that the drive folders are assessable from windows explorer Screenshot

Device I am using
WD Mycloud EX2 Ultra with WD Red
OS: DSM-wdmc-mirror-gen2-8451(made by you, thanks a lot for this)
Please reply as soon as you can waiting for a response

@Rand I am unable to go through the complete thread, but i am facing the same issue on my WD EX2 ultra, No UI after 1 day or over night

Known issue:

Thanks for issue but i am unable to follow the fix,

  1. Device will boot to DSM installer), : Done
  2. connect via telnet, not sure what is this
  3. plugin HDD’s back. Done
  4. Mount Rootfs, How to do it?
  5. replace libs, : where and which files
  6. reboot.

really appreciate your work, look forward to response.

Stuck here

unmount -> umount

Thanks for quick response, I was able to connect to telnet using putty reached the location /usr/lib but unable to use unmount of replace file via putty, and filezilla does not connect to root folder, sorry for this small questions but i am a newbie with all this, really appreciate if you could help me with bit detailed steps, thanks in advance.

Hi Fox_exe,

too bad that you gave up on “WD Alternative Firmware”. Hope you can help me anyway. I have the Debian app installed, but when I try to upgrade to DebianStretch I get the dbus package error: “script returned error exit status 127”. So my first question is there an easy way to upgrade to DebianStertch. And my second question is how to bind directories to the chroot on bootup, because fstab changes in WD firmware and also in the chroot environment will be ignored.

@Q-Fireball, try apt hold dbus and run upgrade.
For add startup commands - edit /mnt/HD/HD_a2/Nas_Progs/debian/ (and

  • Use [Tab] for auto-complete path when type in console.

Thank you very much!