Synology OS on WD my Cloud - new Hope


#1

I was researching about how to replace our current WD firmware with another one and i only found the great efforts of  Fox_exe, to install clean debian or OMV  which is great but still is not very friendly for me 

but i came across the synology DSM 5.1 and it looks great and i had alot of features

I then found that Synology has a box DS414j works with the same processor type which is the  MINDSPEED Comcerto C2000

and they have a version of the software compiled for it here  synology DS414j OS Pat file and also the source code is here  synology Source Code for MINDSPEED Comcerto C2000.

so i started to think will this be an option to install the Synology DSM 5.1 to our WD my cloud

can someone from our experts take a look and direct me on where to start ?


Turning WD My Cloud into a NextCloud Box
Turn off/ Shut Down WD My Cloud using Android?
OS X or Window 10 network boot
WDMycloud and Western Digital softwares
WD Sync and macOS High Sierra
#2

Hi and welcome to the WD community.

I have not tried this, but lets see if another user can help you out with some tips and information on how you can start your project. 


#3

Hi ArMak

Thanks, for your wishes

it would be great if we can do it


#4

Here is my trials to this but so far no success

  • I have downloaded the firmware of DS414 pat file
  • Extracted the Pat file
  • there are many files including the uboot image, kernel zimage and the disk image also there is a file named rd.img my understanding that it contains the ram config file
  • I have managed to get the mycloud to boot loader mode by sending a Magic packet to stop the normal boot sequance
  • pushed startup.sh by TFTP to mycloud and the startup.sh loads the kernel also from TFTP
  • tried pushing Zimage as a boot image but did not work
  • tried pushing uboot image as boot image but did not work
  • tried building a rom by combining uboot with zimage and rd.bin but still did not boot

any other thoughts are appreciated

I will share the detailed steps and references from other posts later tonight


#5

Be cautious…

DISCLAIMER:  This forum is not a WD Legal Venue, and I am not a lawyer, so take this for what it’s worth.

Putting someone else’s code for which you did not buy a license on another platform may bring trouble…

If you’re not buying a Synology NAS, you’re not buying a license to use their software.

All you’re entitled to use is the GPL code, which is the only source code Synology must release.


#6

All you’re entitled to use is the GPL code, which is the only source code Synology must release.

Depends which version of the GPL the code is using.  I’ve just torn out a useful article from a technical journal about FOSS*, which says:

“Other licences - sometimes termed ‘copyleft’ or ‘viral’ licences - require that all software, even if you have added to it or modified it, must be made available publicly, usually under the same licence terms.  One example of such a licence is GPL (currently GPL Version 3).”

My understanding is that the Lesser GPL only requires you to make public changes you have made to the original code base, and that you are not obliged to make public any additional code you have written around that code base.

I would suggest that if Synology have released it, then they must be working under the full GPL; why would you release your intellectual property unless you were legally obliged to do so…?  If they haven’t released all their code, you won’t be able to make a Synology image that will run on a WD platform, as the code will be incomplete…

Likewise, IANAL, and *Free and Open Source Software is an interesting branch of Intellectual Property Law…


#7

Hi TonyPh12345 and cpt_paranoia,

I am not a legal guy

but what I know and that Synology operates under full GPL and they have already released the source code for all their versions with deferent HW flavors for pubic

It is on sourceforge for public download from here   SourceForge reprosatory

I am not publishing any code or binaries for anyone all the code and binaries are pubished in the offical synology website

I hope that i am not in violation of any laws :) 

thanks for the advice :slight_smile:


#8

Test build complete:

https://drive.google.com/open?id=0B_6OlQ_H0PxVa040STRHQUU3VU0

Works fine. But need more tuning/tests/optimization/etc…


Serendipity: Why I bought another 4TB Cloud
#9

Man you are a king :smile:
I will try it and let you know :smile:

I will be more than happy to test for you :slight_smile:


#10

Hi Fox
I have tried to load it but here is what happened
i was able to load it the bootImage and boot the OS but temp ( if I lose power it does not boot "
the bootsata does not seem to work
I have managed to boot it temp by modifying your old TFTP startup script to include the bootsata paratmeters and replacing the bootimage with the boot image of the DSM

but if I lose the power i have to TFTP the bootimage again
any chance to make this permanent


Problems with mycloud device .....& hopefully solutions
#11

I think, i fix it all.
Redownload scripts/images from Google drive.


#12

can anyone come out with a tutorial on how to instal DSM on wd EX2?


#13

This sounds awesome!
Super keen if someone can make it (intermediate) user friendly!


#14

Impossible for now - different hardware.
Need build new kernel and change few scripts.

If someone borrows me the device for a while - I will make the version for you (More info in PM)


#15

Hello Fox_exe,

I too am eager interested in the possibility of having the Sinology GPL software working on my EX2. I already am running the XPEnology software on a Dell desktop with great success and happiness, but can only imagine how great it would be, running on this very small, portable 2 drive EX2 unit. Possibly I can help advance your already great work and successes so far! :grin:

Thank You,
Greg


#16

Need hardware for test (+ Uart)
Note: Example patch for kernel available on G.Drive (For kernel v3.2.40. Only synology addons).


#17

Hi there, thanks for your work on dsm fox.

I’m trying to build from a bare disk from my old 4tb we cloud, previously wiped.

I’ve follows the partitioning instructions and when I get to mounting sdb3 it fails. Doing an fsck on the disk throws up super block and inode errors a plenty

I must be doin something obviously wrong, any ideas?

Thanks
Stewart


#18

got it almost working. just had to reformat /dev/sdb3

so now it boots, but it seems to have left-overs from my old WD cloud (device is called MyCloud in the synology finder, login screen background is WD cloud logo)

more importantly, i don’t know how to login? what is the admin password in your image? or is there another way to reset it

thanks
Stewart


#19

sorry, just seen password at top of instructions.

many thanks for this build - really helpful!


#20

I did it just for lolz :smiley:
You can change it in “Apperance” or in “User settings” (For admin, top right button in web gui)