Problems with mycloud device .....& hopefully solutions

Hey I’m a new user so please be gentle ,I would be interested in doing this on a WD Mycloud 2tb Synology OS on WD my Cloud - new Hope.
Mainly to solve a few issues I am having .
First off im running the v3.X firmware because v4.X had several issues trying to install and run transmission.So at the moment I’m rumming a v3 mycloud 2tb with tranmission & an rss patched in via contrab . all thanks to the community which is amazingly supportive.
so im hoping so one might be able to chime in and help out a little here …Please so far i love the Mycloud but I’d love a way to solve these issues.

Primary issue at the moment is that remote access to the box seems impossible right now .The mycloud web login will only work run on the latest firmware which is fair enough i suppose .
I’ve ssh on and tried ssh-ing the box remotely mycloud with no luck. I am on a static Ip
Which could be because my router does not have an option for port forwarding first time I’ve come across one without that.
I’ve little experience with ipv6 which is only adding to the confusion .

Would the above os potentially solve the remote access issue or would there be a better way to solve the it

Failing that is there a way to remotely add torrents to transmission .I’d almost give up on full access if i just had that . at this point im open to all suggestion that would be helpful

Hello,

I have not tried this, but lets see if another user can share some information or tips on this matter

1 Like

Thanks for the reply it’s much appreciated .Here’s hoping between the community and the new router virgin/upc are sending .There will be a solution

Apparently to fully use the MyCloud.com portal you have to be running the OS 3 version firmware on the My Cloud. And have remote access enabled via the My Cloud Dashboard, and a User account configured for remote access.

If you cannot configure port forwarding on your router then you won’t be able to remote access via SSH to the My Cloud without using some other method of getting past your router’s firewall.

Not sure why you need IPv6. Your broadband provider may or may not even support IPv6. And if they do support it your router would need IPv6 support. For remote access IPv6 support is not from what I understand required or needed.

hey Bennor thanks for the reply .
I am using version 3 of the firmware and still no go through the my cloud portal

After ringing upc I got a router out with port forwarding and have set it up .I’m still not getting any results .Also interestingly enough when I use an external ip and ping the home address the port comes back as closed. As per your advice i gave up trying to use ipv6 and found my ipv4 address .Im really at a loss here kind.
I’m really at a loss here any advice would be appreciated

Are you sure your using the right public IP address? Do a Google search with the term “what is my ip address” and it should return your public IP address. That is the address you should be using.

The MyCloud.com portal may not work properly (or at all) with any firmware prior to v04.04.00-303. The “OS 3” firmware I believe started with v04.04.00-303 and later firmware versions. Latest firmware version is v04.04.01-112. Its possible even the WD mobile apps and Desktop software may not work properly with firmware prior to v04.04.00-303.

hahahha I can certainly attest to the fact that they don’t work without OS 3

i’m using the correct addresses found via the site http://ipv4.whatismyv6.com/.this gives me both addresses and those are the ones i enter as what i want to ssh into.I either get connection refused or timed out depending on the machine.

ah right that I’m running OS 2 ,I guess my next question would have to be has anyone got a guide for torrenting on the v04.04.00-303.I’m open to any programs have tried running transmission on the OS 3 but that had dependencies issues which i could not resolve .I ran through a few guides for it but all with the failed end result