Turn off/ Shut Down WD My Cloud using Android?


#1

Hi. I was wondering if there’s a way to shut down My Cloud from my Android Phone? Are there any third party softwares that do this job? I do not see “Shut Down” or “Hibernate” tab on “WD My Cloud App”. Any suggestions will be appreciated. Thanks :slight_smile:


How to stop a WD MyCloud 2.11 from a local station?
#2

You can but who will be there to reboot it if you leave and are away from where it is located? See images below captured on my Samsung Galaxy S6. I was using my Firefox browser.

Click on, tap or activate image to enlarge it.


#3

Thanks for your reply. I bought this just because I wanna hear songs on my mobile when I’m going to bed. So I don’t care about reboot, as I will turn on the device only the next morning. I have a lot of songs that cant fit in my memory card.

Anyway, unfortunately I do not have the Shutdown option in my UI.

This is on my PC by the way. I’m sure that on my mobile, the case will be the same as well. I think for newer models WD has disabled Shutdown option which is a pain. I wish WD enables this option ASAP.


#4

I just cross checked with my mobile. Same snapshot. No Shutdown option on the UI :disappointed:


#5

You may want to read this discussion on the shutdown of version 2.

Maybe WD will get it corrected.


#6

In addition to performing a shutdown through the Dashboard UI as the previous post indicates one can use SSH to issue the shutdown or reboot command to a v4.x firmware version My Cloud. However, as the previous post states there is no way to restart the single bay My Cloud once shut down. One has to remove power then reapply it in order to restart the My Cloud from a shutdown state.

For Android, I use the SSH Button app on my Android phone. Note: Replace the SSH host name with the IP Address of your My Cloud, and replace the SSH password with your password if it has been changed. The following commands may only work on v4.x version My Cloud’s.

Shutdown and power off:
Command: /sbin/shutdown -h -P now
SSH hostname: 192.168.1.10
SSH username: root
SSH password: welc0me
SSH port: 22

Shutdown only:
Command: /sbin/shutdown -r now
SSH hostname: 192.168.1.10
SSH username: root
SSH password: welc0me
SSH port: 22

Power off only:
Command: /sbin/poweroff
SSH hostname: 192.168.1.10
SSH username: root
SSH password: welc0me
SSH port: 22

Reboot:
Command: /sbin/reboot
SSH hostname: 192.168.1.10
SSH username: root
SSH password: welc0me
SSH port: 22

See the following previous threads that discuss how to shut down or reboot the v4.x firmware version My Cloud (from the same local network) using a mobile device:

https://community.wd.com/t/safe-shutdown/147307

https://community.wd.com/t/shutdown-mycloud-from-mobile/157418

https://community.wd.com/t/mycloud-startup-shutdown-using-an-ipad/148423


Wie kann man die MyCloud 2TB herunterfahren?
#7

Hi. Bennor. I tried the first command and it failed. I entered the command exactly as you suggested and when I tested it, this is the message I received.

And how to determine what version I’m using? I have the firmware “2.11.140”. Is there something that can be revealed from this?


#8

As my post above indicates: The following commands may only work on v4.x version My Cloud’s.

Because you have the v2.x My Cloud (newer generation than the older v4.x version My Cloud) the commands are probably in a different place/location. If you see the Safe shutdown link I posted above one user mentions the proper command to trigger the shutdown on v2.x My Cloud’s: /usr/local/modules/script/shutdown.sh. See the full command at the end of this post. And that same user then confirms it works, that thread continues from those two posts with other discussion that may be relevant including a second user who confirms that SSH command works under v2.x firmware.

https://community.wd.com/t/safe-shutdown/147307/26

SSH command: /usr/local/modules/script/shutdown.sh -h now


About SSH "poweroff" command
#9

Shutdown doesn’t really do that much…the power remains connected, and the device stays warm, so I’d suggest there’s not too much point. The device is designed to run 24/7, anyway. And, with luck, and the sleep mode enabled, it should go into sleep mode on its own.


#10

Thanks cpt_paranoia and Bennor. I have tried what Bennor posted. But getting the same error message as indicated above, I guess I’ll have to leave in ON then. Man. They have made customer’s life hard on this WD v2.x firmware.

I primarily use this to watch movies and songs during night when I hit the bed. Assuming that I turn OFF the device only the next day morning (Since the device is located in another room), will the lifespan become shorter for this drive (Since it will be turned ON the whole night, everyday)?

Thanks.


#11

Maybe now that shutting down the device is harder on the v2.x firmware, I guess we should think about ways to convert a v2.x to the original v4.x firmware. Lol :smiley: (Which should be a discussion for a new topic overall)


#12

The two versions of the single bay My Cloud use slightly different hardware. Currently (and officially) one cannot install the v2.x firmware to the older generation My Clouds that run v4.x firmware. Same goes in reverse, cannot run v4.x firmware on the newer generation v2.x firmware.

Gen2 (v2.x):
Processor: Marvell armada 370 (2core, 800MHz)
Memory: 512 MB Ram

Gen1 (v3.x/v4.x):
Processor: Mindspeed Comcerto C2000 (2 core, 650MHz)
Memory: 256 MB Ram

The Gen 2 uses a form of Busy Box as the OS while Gen 1 uses a cut down version of Debian.

What one can do, unofficially, if they have a v4.x My Cloud is install alternate firmware to the My Cloud. See the following threads.

https://community.wd.com/t/clean-os-debian-openmediavault-and-other-firmwares/93714

https://community.wd.com/t/synology-os-on-wd-my-cloud-new-hope/95650


#13

WOW. These things seem so complicated. I guess I cannot do anything. I’ll just leave it ON all the time then. I should soon buy a cloud service like Dropbox or something to secure my data.

Anyway’s thanks a ton for your input Bennor. I have learnt a lot from this forum.


#14

I’ve enabled the SSH in the configurations and I’m using the JuiceSSH on my phone to connect to it and send a “shutdown” command.

I miss a power button on this device.


#15

There is no “Power control”. WDMC - Like a router - cant shutdown completly (CPU still consume energy. Only HDD will turned off. And need disconnect device power for turn on again. There is no “WOL” function.)

About power control from WebGui - Its present, but locked (Like “App control” and ISCSI functions). Need edit /usr/local/model/web/pages/function/define.js for unblock these functions.


#16

But it’s better than pull the plug from the wall without stopping the hard disk first.

[]'s


#17

Not a problem, if disk not in use (For RED series).
And - WDMC - is that kind of device, what poweron 24/7


#18

Yes it is. I was having problems with some media files becoming corrupted (some how) when I just simply pulled power to the My Cloud when not in use. Issuing the shutdown command first then pulling power once the front LED is off solves the problem.