After upgrade to OS 5 my iscsi target volume is not working

in the dashboard ISCSI target is in creating status with 0% . no luck to getting my volume back. i lost completly my data volume.

@senthil.anand please collect the system logs and send to support.

How to Collect My Cloud System Logs

Answer ID 18374

@SBrown, already collected system log and send to support.

Looking for solution to get my data volume back in to access . currently my target list shows as below.

This is senthil working from gulf computer services( we are partner/reseller in Bahrain for western digital products). we sold this mycloud ext2 ultra 8TB NAS drive to our client, and we configured this drive in their office and configured storage as iSCSI and created 7.9TB data volume. This volume drive mounted in to their file server and they started kept their work data in to this volume last one month. now suddenly this drive missing from server. then I check with dashboard current iSCSI target list shown as below . this is happens exactly after firmware update on the drive we enable auto update option.

Kindly provide us to restore this drive back as previous condition without losing data . this client already disappointed with us.

@senthil.anand I checked your case Reference # 210208-003427 and there are no system logs attached, only the screenshot. Someone from opened case 210209-002102 and attached the system logs.

The RAID volume is 100% filled to capacity

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda4 951204 124908 809912 13% /mnt/HD_a4
/dev/sdb4 951204 76 934744 0% /mnt/HD_b4
/dev/md1 7744026364 7734757924 0 100% /mnt/HD/HD_a2 <------ FULL


Some data has to be removed from the device and the device itself rebooted to get it out
of it’s current state.

  1. Follow the KBA listed below to get the size of the OS3)Apps_Backup folder and delete it.

My Cloud OS 5: Remove .wdmc and OS3_Apps_Backup Folder(s) to Reclaim Disk Space

  1. Delete content until the device is at least 95% disk space free.

  2. Reboot

  3. Login to the Admin UI and Turn Off Cloud Access.

  4. Check the iSCSI status again

@SBrown ,

previous case ref no was wrong.
please note the following correct case reference no # 210209-002102

i attached system logs on this case ref number.

as i mentioned before my iscsi volume contains full data’s. i need to restore the iscsi volume without loosing data… this is my main concern. kindly provide me your valuable advice and support to resolve my case



HI @SBrown ,

i am the one opened the support case 210209-002102 no for

i tried the above solution and my OS3_Apps_Backup Folder size was 302 MB and i delete that file aswell removed .wdmc file also. after deleting and follow above instruction restarted and checked , but my iscsi status remain same as creating status with 0% and greyed out.

Now that you have cleared some space.

  • Turn OFF iSCSI
  • Turn On iSCSI
  • The LUN should be restored successfully.

Dear Sir,

i tried above steps of turnoff and turn on back iSCSI. but still remains same status.

iSCSI shows creating status as 0% not accessible.

@senthil.anand Were you able to free up disk space from being 100% filled to capacity and resolve your iSCSI issue with the steps provided?

no . so far i couldn’t able to access my iscsi volume, all the steps followed and freed some space as per steps. but still in same creating status only. this client is already disappointed with us , as they are thinking we are good IT solution product provider. we are local WD partner reseller in Bahrain. we supply lots of wd solution to our end customers. this is first time we face such issue. so far i didn’t get any technical team involvement for to resolve my case, which was created more than 3 weeks, and i am trying to get chat support but no luck… really need some support as earliest to resolve our case. i don’t know what to do now.
there is full customer data’s already transferred in to this iscsi volume. need to retrieve the volume back to working as before firmware update.

Can you attach new system logs to your support case so that I can have our engineering team investigate

senthil.anand Did you ever get a response from the team at WD?

@jstonge @senthil.anand if your disk space is no longer 100% filled to capacity, and you have attempted the steps outlined in this thread, please collect new system logs and attach to your support cases.


dear sir,

can you the last update from WD support team for my ticket. they mentioned to clear the space to get access iscsi.

i followed your instruction and removed OS3_Apps_Backup Folder size was 302 MB and i delete that file as well removed .wdmc file also. after deleting and follow above instruction restarted and checked , but my iscsi status remain same as creating status with 0% and greyed out.

now, there is no other files available other than my iscsi volume. i cant delete files from icsci volume where this volume is not accessible.

i dont understand why this problem happened after new firmware update. before update it was working as my share drive volume. i am using my full disk as iscsi volume to use as network share folder access file storage.

it is clear that firmware damaged and created this issue, now i lost my entire stored files under this iscsi volume. i am following this case more than month now. still there is no solution to bring back my volume as before firmware damage.

how can we recommend this my cloud solution to our clients. as i mentioned earlier we are local partner reseller and we supplied this product more than 50 clients and keep selling & recommending this product. but this is first client we are facing issue after firmware update. now we told other clients, not install this OS5 firmware since there is issue.

kindly provide some solution revert back option to get our iscsi volume

please find the ticket i already uploaded latest system logs (after tried clearing os3 /wdmc files and turn off/turn on iscsi cloud option)

@senthil.anand The solution to your issue has been posted in the article listed below

30255 My Cloud OS 5: iSCSI Target Cannot Connect or Create