After updating firmware attached attached devices no longer accessible via Windows

After auto updating to v04.04.02-105 this morning my external devices are no longer accessible via Windows. The drives are detected through the WD desktop, but not through Windows. I have tried with multiple computers, tried rebooting all of the devices (three my cloud drives, and the three USB drives that are attached), and none of the attached devices are recognized.

Have you tried shutting down your router, waiting a minute and then restarting it? See if that will bring them all back up on your network.


I can access the My Cloud hard drives, just not the devices connected to them. If it was a router issue, I would think that I wouldn’t be able to access the My Cloud hard drives themselves. I can access them, I just can’t access any USB hard drive connected to the My Cloud.

Are the Shares for each of the attached USB drives showing up in the Dashboard > Shares section?

Some other things to try:
Check the USB Content Availability setting via the Dashboard > Settings > General page. If On, turn Off wait a few minutes then turn it back On. Or if Off, turn On wait a few minutes then turn back Off.

Have you tried unplugging the external hard drives connected to the My Cloud units, waiting a few minutes, then reconnecting them? Or unplugging the external hard drives from the My Cloud units, rebooting the My Cloud units, after My Cloud front LED turns blue reconnecting them?

I’ve tried all of that.

Are the Shares for each of the attached USB drives showing up in the Dashboard > Shares section?

What program on Windows is not detecting the Shares? What version of Windows are you using?

Yes, the shares worked up until today, and that’s when the firmware was updated. The shares were visible within windows explorer, plex, reaper, iTunes, etc. None of that works now, and based on what is taking place, I figure it has to do with the firmware update.

Sometimes a System Only restore via the Dashboard can fix weird problems with the My Cloud.

A System Only Factory Restore will change all settings back to the factory default ones, makes all private shares public, and removes any administrator password that the device might have. However, data on the network drive is not impacted and remains intact

That did it, I reset the drive, and Windows now recognizes the attached drives. Thank you for your assistance.

I’ve got the opposite. All users can access the drive regardless of access settings.