Adding second WD MyCloud drive to Wd2go (Now

I have not been able to figure out a way to add my second WD MyCloud 4TB to the wd2go (web interface) now accessed via I have added my new 4TB MyCloud to the MyCloud Desktop application and to the MyCloud mobile apps on my tablet and phone. I can access both drives via these without any issue. But when I go to and logon with my WD credentials I can only see my original WD Mycloud and can find a + or an Add function to add my second 4TB MyCloud so that I can access via a browser. What are the steps to add another drive on the web interface?.. Thanks.

Are both My Cloud devices on the same local network?
What is the firmware of the My Cloud device that isn’t showing up on

Some general suggestions:
First, ensure both My Cloud devices have unique names.
Next, make sure on the My Cloud that isn’t showing up on that Remote Access is enabled on the Dashboard > Settings > General > Cloud Access > Remote Access = On. When the remote access connection is enabled and working properly the Connection Status should indicate: Connected (Relay connection established)
Next, ensure you have added your User name to the new My Cloud and have enabled remote access for that user on the Dashboard > Cloud Access > , using the exact same email address that you used for the first My Cloud.
Relogin to and check to see if both My Cloud devices now show up.

Benner, first of all thanks for your reply. Both MyCloud devices are in the same LAN connected to the same switch and in the same subnet. Both running the lastest firmware v04.04.01-112. I followed the instructions that you mentioned above and all of the settings matched. Both MyCloud have Remote Access turned on with the connection status showing as “connected” with port forwarding connection established. They also have the same email under Dashboard > Cloud Access. The one thing that I just noticed is that if I click to resend the registration email on the one that does not show on the web interface I get the following error: “Failed to update device user. (400068)”. If I click to resend the registration from the one that’s connected the email is sent.

FIXED: For some reason even while it had the exact same email I kept getting the same error when I clicked the resend email registration button. Even after rebooting the drive. So, I decided to removed the email under Dashboard > Cloud Access and re-added. This fixed the problem.

One criticism about this new remote web interface is that it’s poorly designed. To access the second drive one has to click the little wheel (usually associated with settings) to view the other drives registered under the same user. Access to all the drives should be clear with links on the main page once you log in.