Accessing My Cloud Home over network?

Having some difficulties with a My Cloud Home device that a client has. It is connected to their network via a switch. I went through the setup process at and downloaded the WD Discovery program.

Using the WD Discovery app, I can see the drive. I can see the same drive and content when I log in to mycloud webpage

The problem comes when I try to access the drive over the network. I see the host name of the drive listed on the network. When I click it, I only see a TimeMachine folder (all the PCs used there on site are Macs). When I click “Connect As” at the top right, I can login as either a guest or registered user. Guest use will not allow me to add files. Trying to login as a registered user has not been possible. It asks for a username/password and I’ve tried everything - admin/blank, admin/password, admin/admin, credentials, etc. I have no idea what the user/password is supposed to be. I’ve fully reset the device and it does the same thing.

I also tried setting up a scanner to scan to the drive over the network via SMB. When I tried using the IP address of the device, it didn’t work. I tried using the host name instead and the printer claims it is connected successfully via SMB and the scan job also completes successfully yet nothing ever shows up on the drive when viewing the WD app and I cannot manage to view the drive any other way.

Does anyone have any ideas?

Hi digitalsquid,

You can refer to the link mentioned below to resolve the issue.