Access Changed to My Cloud via Windows Explorer?


#1

I tried to add some content to my Public drive on my WD Cloud but I was greeted with a wonderful little error!

AccessError

So naturally I tried to change the folder permissions so I could have my regular permissions again, but was again met with another error.

AccessDenied

I perused through the forums here and saw a 4 second reset may do the job - tried that, no joy. I also used the Windows Credential Manager to ensure that the user and password were what they should be, and they were. I’m stuck. Anyone able to assist?

I have firmware version WDMyCloud v04.05.00-320 : Core F/W and did recently go through a Windows update on 7 December to version 1709 for Windows 10.

Thanks for the help all!


#2

The permissions on folders are inherited from Shares. And one sets the Share permissions through the My Cloud Dashboard.

One suggestion. Disconnect any mapped Shares to the My Cloud. Ensure there is no entry for the My Cloud in the Windows Credentials Manager. Then reboot both the computer and the My Cloud and then try to access the Public Share.


#3

So I disconnected My cloud from my mapped drive, deleted the settings from Windows Credentials Manager, and rebooted my computer and my My Cloud, but that didn’t fix the issue. As far as changing my Public Shares setting through the My Cloud Dashboard, this is what I see:

Any thoughts?

I also downloaded the WD Access program hoping that would be a work-around to my Windows Explorer issue, but it also fails to upload content because of the access violation.


#4

How are you trying to change the content? Public is Public and you should not have any problems adding content, depending on what it is.

Here is an image of my Public share on my My Cloud. I have Windows 10 Home with all updates. Click on, tap or activate image to enlarge it.


#5

Have you made any other changes using SSH to modify the My Cloud firmware?

Have you tried another device or computer to see if it exhibits the same error message about file access?


#6

I try to change the content (modify and write) via Windows Explorer. And I agree about the Public access, that’s why I’m so perplexed. I have not made any changes using SSH, no.


#7

Here’s what mine looks like, and I cannot add/change anything in that Public drive either, see screenshot below.

MyCloudPublicDrive


#8

Were you able to successfully modify the share or folder permissions using Windows File Explorer? If so that may cause problems since the My Cloud, because it uses Samba, may have problems with Shares or folders within Shares that have their file/folder permissions and owner modified outside of the My Cloud Dashboard.

In the screen capture above what is the file .vftTestData? Never seen that before on a My Cloud.

Can you copy files into other Shares/folders outside of the Public folder? If so you may have to use SSH to access the My Cloud at the “root” level to see what the permission settings are on the Public Share and who owns the Share/folder.

For example at the SSH/root level of the My Cloud I use (first gen v4.x single bay) using WinSCP, indicates the following for the Public Share properties.

PublicProperties


#9

Honestly, no idea what that is. Same with the .DS_Store, I thought they were default files since they’ve been there for years lol.
I downloaded WinSCP and looked into it on my end as well, but our properties look identical to me


#10

If I remember right the .DS_Store file is created by Mac OS computers.

As a troubleshooting step do you have another computer or mobile device that you can use to copy files into that directory/Share?

As another troubleshooting step you could enable FTP through the My Cloud Dashboard > Settings > Network. Then use an FTP client software (like FileZilla - https://filezilla-project.org/) to upload a file.

Either option may help isolate where the problem may lie.


#11

Oh, that makes sense. My son used to have a mac book and I had access for him a loooong time ago. And no, I don’t have another computer to test on. I tried using Filezilla as well, still the same issue and error messages with the access denied.

FileZilla


#12

Maybe try a 40 second reset. More information on how to perform a 40 second reset and what values are returned to default values are explained in this WD Knowledgebase article.

How to reset a My Cloud device | WD Support


#13

I did the 40 second reset, same issue, cant write or modify anything on the drive. What I did find interesting was this error when trying to access my personal share that it created:

JoshuaError


#14

I also cannot create a new Share via the WDMYCloud Dashboard either:


#15

That screen capture indicates that are attempting to use a second user name on Windows to access a Share on the My Cloud. Windows doesn’t like users using more than one set of credentials to access a Private Share on the My Cloud.

Couple of suggestions. Disconnect any mapped Shares. Access the My Cloud Credentials Manager and remove any entries for My Cloud. Then Reboot the PC and try to access the Private Share again.


#16

We tried that earlier in the thread and it still didn’t work. The key issue is still that I cannot modify or write to my public share.


#17

Any other ideas all?


#18

I am having exactly the same problem and it is since the firmware update (WDMyCloud v04.05.00-320 : Core F/W). I emailed WD who advised to ring their support number but I’m struggling to because of work shifts. Any help here would be appreciated.


#19

Hello. Did you manage to get this resolved?