9 digit code is not working for My Cloud Home


I have purchased My Cloud Home 3TB in the UK, and im trying to set up this device in India. I do have connected the LAN cable properly, and the internet is working fine and its power ON perfectly, I can able to see the white light blinking steadily.

I have created an account and logged in to home.mycloud.com after I enter the 9 digit number its keep on throwing an error: “It seems your device isn’t connected to the internet”. I have installed WD Discovery and tried but still same issue.

Note: I have tried on both Windows 10 64 Bit, and also on Mac 10.14, the issue is same.

anybody please help me here. thanks in advance.


I still don’t know whats happening with “my cloud home” for the past 14+ hours the led is started blinking slowly in white color. and i’m unable to discover the network drive on Macbook OSX 10.14.

The led needs to be steady, not blinking, white. A steady light means it is connected to internet, which is required for accessing.

Hi Carl,

Thank you so much for the reply.

I wanted to clarify one thing please, the LED its been taking slow breath for the past 4 days, though the internet connection has been established, bcz I have check in my router console, there the LAN IP address ( ) has been assigned to My Cloud Home. what could be the problem I’m still not getting it… please suggest how to check whether the internet connection is established to device or not ? Thank in Advance.