My new Mycloud Home Not working?

Hello All,
I just bought MyCloud Home 3TB from a local store.
I have connect it to the router and the LED is breathing all time.

i’ve checked the router, it seems that the device took an IP from the router DHCP.
i’ve tried to add it to mycloud home app, but it keeps showing up “Oops! Somthing’s not matching up”.
i’ve tried to access it via the browser, it keeps showing up w weird message says {“Key” : “notFound”, “message” : " Not Found:}.

I tried different router and different network cable but same problem.
I tried to reset it, but same problem.
I tried different internet connection, but same problem.
I tried to access it Via SSH, but the connection was denied.

Please Help.

1 Like

Have you looked at the User Manual?

Really dude!!!
Are you kidding to me ??


Maybe it needs to update to the latest firmware.
Do you know which version you are running?

The device is new.I just get it out of the box.
I cannot logging into it.

I cannot see any configuration for it.

WD hasn’t made the 3TB and 6TB versions of MCH for a while and many resellers don’t sell them ‘new’ but some refurbished units are available.

You have not mentioned if Western Digital officially provide service in your country. Is it possible that WD has blocked server service based on your geolocation?

You probably have not checked:

  • Device serial number for warranty status. Perhaps it is out of warranty already and you won’t want to keep it.
  • Device debug_logs.tar. Search the forum and knowledge base for several methods to get it.
  • The debug_logs will let you know if the device is stuck in what firmware version, serial numbers of the MCH and the hard drive, hdd model and the state of the hard disk in the device.
  • Direct cable connection. Recently, it was reported by some guy that you can directly connect the My Cloud Home to the computer and get access to it with Internet connection sharing (ICS). It could let you provide an internet connection to the MCH which bypassed the router. Search for ‘ICS’. It is possible to use ICS together with a mobile hotspot or other WiFi as the source of connection sharing.

If it’s brand new (ie you have no data on it), maybe you can try factory resetting it… 40 seconds pin in the back.

Hello All,
I tried the reset but nothing happens.

The device is not used before (but i think its older versions), the local store make a discount for nonsold items, and i took it.

I checked the serial number for warranty, and its expired in 2020.

I have send the logs to WD support, they didn’t respond yet.

There may be nothing wrong with the device and It may be possible to activate the MCH even if it is located outside of the supported area. You may just have to have it plugged in with internet and wait perhaps a week to 10 days. The MCH may not do back to back firmware updates, so it may just have updated to 7.16 and waiting a week to update to 9.4. You can read the OTA log yourself.

Similar situation may have happened to firmware updates of some MCH located in Russia in July 2022.

Jul 10

If everything is configured correctly and the port is available, then in the logs where errors are found in the wdc folder, the ota line should display the message timeout of the waiting time has passed type … Then leave it without touching it for a couple of days and it will update … If there are errors in the ota line, then the update will not pass, the port or address error will be written …this is all in the logs

Kindly note that the WD is still not updated.
I cannot return it back to store.

Im hopeless and disappointed and so muck shocked about WD.

If you’re really want to help me, send me a new branded one to my address in free.


Did you fix this? I have the EXACT same issue.

Still have this problem.

The only solution is to throw this device from the window.

This really appears to be a case of a local store selling a product that is not supported in that country and has not even tried to help their local customer. You haven’t mentioned where you are located and it will help your countrymen if you do, but it doesn’t really matter. Even if WD send you a free replacement, it may not be possible to activate and work from your location. You have already opened a case with support and you will need to wait for their reply.

My country is Palestine :palestinian_territories:.
I have opened a support ticket, but unfortunately they are helpless.

1 Like

Several choices:

  • Call the nearest support office, which is in Israel. See if they are any better.
  • Sell it. Sometimes it is easier that way.
  • If you have friends or family in Israel, reset the device once more and send the MCH to them to see if they can plug it into their internet and activate it that way. Wait 7 to 10 days.
  • If you are good at hacking computer hardware, try to install Debian-OMV6 on the MCH. Such as this person did here.

Europe, Middle East & Africa

Retail Customer Support

Israel Ask a Question +80021102110 Local Time
M-F 9am - 6pm
(local charges may apply)


If you want a person to know you are replying to them, use the @ and select their name. See example image below.

1 Like

HI I have similar issue. how can it be fixed

Also how to see the logs on My cloud Home I have 8TB unit

You have to open a support ticket on WD support page, and wait for several years to get an answer like this

I regret to inform you that your drive is corrupted and you will not be able to use it anymore.

Save time and buy synology.