4TB My Cloud disappeared- Fast blinking blue light! HELP

Latest Update…

First, once again, I am puzzled by the fact that the MAC Address that I found, was different that the one i have registered for the drive (which is also the one the label) booting from a pendrive should NOT change this…should it?

Anyway, moving on.

No luck with PuTTY, finally I connected using Windows Telnet client and i got a prompt /#

I wrote and enter all the commands always ending with a prompt back…
Except when I entered umount /mnt/root /mnt/usb

I did not get a prompt back, just the cursor.
Minutes went by, I started typing, but nothing really happened.
After an hour or so…, I closed the window, unpluged the drive and plugged it back on

To my (sad) surprise the drive started with a blinking blue light, and after about 30 seconds, it changed into a red blinking light…

I finally got to how PuTTY worked, (I was using as SSH when I was supposed to used TELNET), anyway, tried the same procedure with PuTTY and with a couple of telnet clients, but I always get to the unmount command then nothing… last time, I left it there, writing NOTHING after the umount command and hitting ENTER, for 8 hours. Still nothing happened. Still blinking red light when it turns on without the pendrive

What happens on the umount command? - I’m no unix user, i read about the command, but i just don’t know why I don’t get ANY response from it… is there any way of knowing what`s going on?

Better yet, any alternative procedure?

PS: The drive seemed to be working (reading/writing noises) all through the night (it was on my bedside table)

Unmount will hang if you didn’t execute the “cd /” command before. I trust you did that. Just to eliminate that possibility. Try to format the USB drive (to FAT32), copy the files again. To eliminate any errors on the USB drive.

Since you are stuck anyway, you may try without the umount command. There is a “sync” command before the reboot. Try that and reboot. During reboot the unmount happens automatically. The unmount and sync are to ensure the copied files are properly done.

On the RED blinking light, there is a thread. The red light keeps blinking. Including the Ethernet connection not being proper…

First, thanks for your help!!!
Now… Yes I entered the cd / command before.

I will try formatting the flash drive and copying everything again and just to rule anything else, I’ll do it into another flash drive.

It there a command that I could run that shows me if there’s something happening?
Sync should take… How long before getting the prompt back?
Using putty to telnet or windows telnet is the same thing, right?

The red light… I don’t know that’s new…which worries me, because something obviously did change after I ran the sequence. And I get the red flashing light on the front, with or without connecting the ehternet cable.

The gen2 front led turn red when the network cable is pulled.

It didn’t happened before. Before it was blinkg blue regardless of whether there was or not connected. Now it’s the opposite, red whether it’s connected or not…

Cross posting my post from another recent thread where the flashing blue front LED is being discussed. The following link deals with the second generation (v2.x firmware) single bay My Cloud and the two methods used to attempt to unbrick it and restore the firmware to it.

If you don’t know which single bay My Cloud version you have, check the P/N number on the bottom of the enclosure. P/N ending with -00 indicates first generation v3.x/v4.x single bay My Cloud units. These units have a slightly different unbricking process than the second gen units. P/N ending with -10 indicates second generation v2.x single bay My Cloud units. The link above deals with the second generation units.

From bad to worst?

So, i bothered one of the IT guys of my company, to see if he could spare me a few minutes
He tried the steps and got the same results.
He was able to navigate through the drive and found the partition (I think, he told me something3?) where all the files were…

He also opened several telnet windows and was able (don’t know using what commands) to tell me that, on one of the steps, there was a problem creating one of the partitions

He told that using the command e2fsck /dev/sda3 to repair the partition

After this, he booted once again, using the flashdrive and this time TADA!!! all the steps
No errors and no delays with any of the commands :smiley::smiley::smiley:

However, :pensive: after the reboot -f command, we weren´t sure when to remove the flashdrive. we tried it right away and the telnet connection died, but the drive did not came back (same amber/red light)

We tried hitting enter and inmediately pulling the flashdrive - nothing (same thing)

reboot -f and a couple of seconds after getting the prompt back, unpluging the drive, pulling out the flash drive, but no luck…

Whenever the drive boots without the flash drive, after 30 seconds or so, RED FLASHING LIGHT

So…there’s the situation

Now the questions

He told me that MAYBE the files on the pendrive where not correct for the drive BUT I’ve checked I have a gen2, the files that I downloaded were supposedly for gen2 mycloud… I already tried a different pendrive

Can I run a check disk of the entire drive from the usb booting pendrive?

He told me that MAYBE the files on the usb flashdrive were not correct for my hard drive BUT i checked and I DO have a gen2, and these files are for gen2 mycloud…

Can I ran a check disk of the entire drive, using the usb flasdrive? If so? how?

Since I see that the files are there…can I copy them somehow? (how?) - The IT person told that copying with telnet is practically impossible and slow. That if the booting flashdrive had SSH there would be a different story

If I can access & copy the files (there about 300Gb of files that I would really need), then I would move to formatting the drive with no problem…

Unfortuntately I can’t take any more time of IT…

Anybody can provide help?. I don’t want to give up on my files just yet.

Still hopeful

When you and the tech were booting the device was it connected to the internet?

Nop. It was only connected to the router. No internet

Sorry what I meant was connected to the network. The following are the causes of the red led.

Disk thermal warning threshold exceeded (under or over temp)
Ethernet cable not connected
Disk SMART failure
Data volume does not exist
System volume does not exist
System thermal shutdown (75 C)
If red led is not because of the network connection. You should be able to see the My Cloud connected in the router. Not sure if the recovery image has dhcp enabled or has a fixed ip address. If dhcp is enabled it should find an address on any network. If not enabled, depending on the ip address it would need to be on the same network. IE 192.168.1.200 then it needs to be on the 192.168.1 network.
You might be able to use Microsoft network monitor 3.4 to see if the My Cloud is trying to get an ip address.

Without the USB flash drive, mycloud does not boot, it does not appear on the network.

The router is set to dhcp and there’s only the notebook & mycloud connected. I kinda doubt there’s a temperature issue, and about the ethernet, whether it was connected or not the ethernet port, when the problem started I got blue blinkg light, after using
the USB flash drive, (when I took it out) it is red blinking…

Is there a command to check the whole disk from the telnet window?

When you power on the My Cloud. The led first blinks purple. Then goes to a flashing blue. Once the My Cloud has completed the boot process the led goes solid blue. I definitely would try the monitor. If the flashing blue turns red the most probable cause it no network connection. The main problem with this device is that you need to be able to do a vulcan mind probe is see what is going on.
Another thing you could do is when you have the telnet connection you could try to mount the sda2 partition. The comands would be
mount /dev/sda2 /mnt
cd /mnt/.systemfile
cd log*
ls
cat

The output of the ls command should show log files. if you cat the files look for errors.
I think the command get will download the file to your laptop. From there you can use notepad to look at the file.

Yes, it does starts purple, then turned blinking blue, now it starts purple, 30 seconds or so of blinking blue, finally changes to blinking red…

BUT, if there’s a network problem, how come I can boot up using the pendrive and telnet and do stuff?

One thing that I found extremely weird, was that BEFORE this problem, on the router, the MAC ADDRESS was one, and when I used the flash drive to boot, the MAC ADDRESS is a different one (!!!)

I’ll try your suggestion, now…why sda2? what’s on there? the boot partition?

Then…" From
there you can use notepad to look at the file" What should I look for?

(Thanks)

sda2 on a gen2 is the data partition. There should be several log files called
mycloud.log orion_cm.log user.log wdmcserver.log
mycloud.log.1 orion_cm.log.1 user.log.old wdmcserver.log.1

The .1 is the older log.

I just tested the telnet connection on my gen2. The commands do work. If using putty you can setup putty to log the console to a file. The file is called putty.log
mount /dev/sda2 /mnt
cd /mnt/.systemfile/log*
ls -l
cat

Not sure if this will help others but the following thread details what worked for one person to fix the fast blinking blue LED post gen 2 firmware update.

1 Like

Success!!! This just worked for me! Mine bricked the same night as everyone else… I’ve been quitely (and painfully) watching these boards. Thank you SO much for everyone’s time and effort. Please check out that fix. The e2fsck was the key for me.

https://community.wd.com/t/success-recover-my-mycloud-3tb-with-fast-blue-blinking-light-after-update-firmware/236186/

Thanks for the try…but no luck, I followed all the steps succesfully I guess, but when I boot without the pendrive, the drive boots to a red flashing light, no luck finding it on the network, thus no telnet, no pinging… I even tried, during one of the runs, esfsck to sda1 - 7 just to see if that would do anything… but no luck

Ok, so I did what you told me, here’s the result

mount /dev/sda2 /mnt
cd /mnt/.systemfile
cd log*
ls

/mnt/.systemfile/log_WCC4E2FYXJT4 # ls
-rw-r–r-- 1 root 0 0 Mar 27 2019 mycloud.log
-rw-r–r-- 1 root 0 244 Mar 27 2019 mycloud.log.1
-rw-r–r-- 1 root 0 5074 Nov 17 2017 orion_cm.log
-rw-r–r-- 1 root 0 224400 Nov 17 2017 orion_cm.log.1
-rw-r–r-- 1 root 0 57238 Mar 27 2019 user.log
-rw-r–r-- 1 root 0 103473 Mar 10 2019 user.log.old
-rw-r–r-- 1 root 0 0 Apr 21 2017 wdmcserver.log
-rw-r–r-- 1 root 0 0 Apr 21 2017 wdmcserver.log.1

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat mycloud.log.1
2019-03-27T03:00:03.707537-03:00 di=UZOWkQV0Zh notice upload_firmware: { “msgid”:“alert”, “level”:“info”, “code”:2026
}
2019-03-27T03:00:17.528376-03:00 di=UZOWkQV0Zh notice upload_firmware: { “msgid”:“alert”, “level”:“info”, “code”:2004
}

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat orion_cm.log
2017-11-17T09:43:33.694360-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::httpPostOrPut curl_easy_perf
orm Error: [Timeout was reached] URL: [https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboarded_devices/0090A9ECE
B3E?local_ip=192.168.33.166]
2017-11-17T09:43:33.694534-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::updateRemoteOnboardingInfo -
httpPostOrPut failed to create/update onboarding info for url https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboa
rded_devices/0090A9ECEB3E?local_ip=192.168.33.166
2017-11-17T09:48:33.696228-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::httpPostOrPut curl_easy_perf
orm Error: [Couldn’t connect to server] URL: [https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboarded_devices/00
90A9ECEB3E?local_ip=192.168.33.166]

… (many lines 'till this is the last one)
2017-11-17T10:35:24.616011-03:00 di=UZOWkQV0Zh 3 MyCloudDrive OnBoardingD: OnBrdNetLocComm::updateRemoteOnboardingInfo -
httpPostOrPut failed to create/update onboarding info for url https://discovery.wd2go.com/on-boarding/api/1.0/rest/onboa
rded_devices/0090A9ECEB3E?local_ip=169.254.34.24
/mnt/.systemfile/log_WCC4E2FYXJT4 #

/mnt/.systemfile/log_WCC4E2FYXJT4 # cat user.log

The first part, I guess it was OK…then we come to 2019-03-27… I think what happened was, indeed, the firmware was automatically downloaded, but failed to be applied…or after it was applied REST API Failed to return success, which is no good (not sure I understand exactly what I means)

2019-03-26T21:48:13.985779-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SAMBA: CIFS: [ipv4:192.168.33.168:58240] connected to [Video] as user [maracanazo].
2019-03-27T00:00:02.548055-03:00 di=UZOWkQV0Zh 6 MyCloudDrive random_chk_central: Set check central server at 2:47
2019-03-27T00:01:06.087076-03:00 di=UZOWkQV0Zh 5 MyCloudDrive root: Rotated atop, atop_size=11619378 atop_upload_size=998
19
2019-03-27T00:47:04.032471-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: Downloading firmware update.
2019-03-27T00:47:05.653414-03:00 di=UZOWkQV0Zh 3 MyCloudDrive root: WD NAS: Email alerts REST API failed to return Succes
s
2019-03-27T02:30:02.201596-03:00 di=UZOWkQV0Zh 6 MyCloudDrive sntp[14044]: sntp 4.2.8@1.3265 Fri Jan 9 06:42:54 UTC 2015
(8)
2019-03-27T02:30:01.851882-03:00 di=UZOWkQV0Zh 6 MyCloudDrive sntp[14044]: 2019-03-27 02:30:02.610861 (+0300) -0.760424 +
/- 0.533911 time.windows.com 52.178.161.41 s2
2019-03-27T02:30:06.270250-03:00 di=UZOWkQV0Zh 6 MyCloudDrive RTC: Set System Time.
2019-03-27T03:00:03.714376-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: Installing firmware update.
2019-03-27T03:00:09.606200-03:00 di=UZOWkQV0Zh 5 MyCloudDrive root: Rotated atop, atop_size=3129962 atop_upload_size=3422
9
2019-03-27T03:00:17.534993-03:00 di=UZOWkQV0Zh 6 MyCloudDrive SYSTEM: The firmware was successfully updated to 2.31.174.0
313.2019.
2019-03-27T03:00:18.364693-03:00 di=UZOWkQV0Zh 3 MyCloudDrive root: WD NAS: Email alerts REST API failed to return Succes
s

Any wisdom that you can share?

Here’s what I did once it started blinking red:

After I went through all the directions and telnet stuff, it has you pull the plug and remove the USB. Once you plug it in it’ll start blinking blue then change to blinking red. At that point, in whatever web browser you use, type in the IP address listed on the bottom of the MyCloud and hit enter. You’ll then get to the MyCloud safe mode GUI. It’ll say something like, the firmware is corrupt and it’ll give you an option to browse your computer and upload a new one. I used My_Cloud_GLCR_2.31.163. Then I clicked apply. It uploaded the file and then says it’s rebooting. I patiently watched the MyDrive blink blue for, what seemed like forever, then bam! Solid blue and back to normal!

I think you’re close. You just need to go to the IP in a web browser. Hopefully that helps! I’m happy to answer more questions!