4TB My Book (WD40EZRX) Won't Power Up (no lights)

My 4TB SATA My Book has suddenly stopped working. It will not power sup. Tried new power cord. Tried different Power Control Board (with the same AB code) and still no luck. When I plug in the power, nothing. Not a peep. No vibration from a spinning platter. Completely dead.

Has anyone run into this problem? Any idea on how to fix it? THanks.

Hi there,

I have not run into this issue, lets see if another user can share information or tips on this matter.

I used my 4TB My Book a second time (within a week of receiving it) and it did not power up. Thought I got a faulty product. Decided to plug it into the USB port in my computer, and the light came on and it worked. I guess it has to be plugged into the USB port on the computer to power on.

I have the same problem too, I sent it back to WD and got a replacement free of charge as it was still under warranty. But now it’s dead again. Trying to find solution if I can replace with another external WD hard drive now.