My Essential Book will not power up


I bought it less than 2 months and it is not powering up. There is no green light appearing when i on the power switch. Seems like the adapter is spoiled. Can you advise what to go about doing it?



A little more details, im using the My Book Essential, 3TB

Its not powering up and i have tried plugging into different plugs to ensure its not the connector issue. It seems like the adapter is not working at all. There is no heat on the power adapter.

Contact customer service they’ll probably send yu a new power supply.


I tried powering the hard disk with my friend’s identical power plug and still to no avail. I just cant seems to diagnose whats wrong with the harddisk. Plugged in, no green indicator light that its running, no noise from the harddisk.

What should i do next? I have tried contacting wd helpdesk but they keep replying me in other languages that i cannot seem to understand. Was told that i can raise a RMA case, but problem is, i have important data in my hard disk that i need to extract out…and i cant do anything now.

Does WD provides data extraction and data protection?

Its less than a few months since i used it…