My Book 4TB not working for my Xbox one anymore

So I’ve had my My book for a couple of months now and I haven’t had an issue till today. Usually the light on the My Book flashes whenever my Xbox one is on, but now the light has stopped flashing and my Xbox doesn’t read it. I have tried the other USB outputs and it still hasn’t worked. Please I need help.


As a recommendation, test the unit with a different power supply and connected directly to the wall outlet.

If possible, connect the unit to a desktop pc to see if the unit is detected under disk management.

So I was finally able to get a laptop to plug it in to and well I couldn’t find disk management, also it restarted and by that I mean it’s asking me to give it a name. I don’t know what to do.

Hey, I got the same problem. My Book 4TB was working 2 days ago, and then today I plugged it in, then there is no power or light flashing in the front. I tried all the recommendation given by the WD Community and Support Article, but none of them works. Would really appreciate some feedback about this too.