3TB w/Thunderbolt (0G03124) disconnecting

I have a new G-Drive connected to a 2013 Mac Pro via Thunderbolt. I’m using the drive as a Time Machine backup but the backups always fail with a messages saying that the drive was ejected improperly. There are no other devices on the same bus. I’ve tried it with the cable that came with the drive and a cable from Apple. The USB interface, it works fine. Is there a know problem with the Thunderbolt interface?


No known issues with the TB interface. Are you noticing these errors after leaving the drive idle to do the backups or are you seeing them live as they occur while working on your system?

Both while I’m using it and when I’ve left it overnight. The last time I tried it I saw the drive icon on my desktop disappear for a moment then Time Machine shows it’s error message.


Do you have any other Thunderbolt devices that you can try to see if you are getting random disconnects. Have you looked into resetting your SMC & NVRAM?

Resetting the SMC

Resetting the NVRAM

This is my only Thunderbolt device. I will try the SMC reset and let you know how it goes.

Resetting the SMC and NVRAM did not help.


Since you’ve tried another cable already then at this point we would suggest sending the drive in for warranty replacement. You can generate an RMA on our website here: RMA creation

Got my replacement drive today. Backups are now working normally. Thanks.