3TB MyCloud seems to have gone missing?

Rebooted my iMac, no dice… its not showing up in Finder.  My 2TB MyBookLive is showing up.  So I unplugged the power cord for my 3TB MyCloud (which had been running nicely since I got it several months ago).  Waited 20 seconds, plugged it back in, then went and rebooted the iMac.  Still not showing up in Finder.

Using an Apple Airport Extreme router, which is connected directly to the MC drive with the same 36" CAT5e cable I’ve been using since I bought it.  This drive is my Media Server, and AppleTV1 is also connected directly to the router, both are sitting behind my TV, 25 feet away from my iMac.  The 2TB MBL is sitting on my computer desk, connected to the Netgear GS108 ProSafe Switch.  All hardwired and wireless devices are working except the MyCloud.

What should I do?  I am not a network type, but can follow instructions. LOL

Is the front light on the NAS blue?

If yes, when you type the IP address of the NAS in safari, can you access the UI?

Actually it was white.  I disconnected everything for about an hour, then reconnected and eventually it all came back.  I have no idea what caused it as the router and the drive are both hooked up to a Battery backed-up UPS and like I said… the _ONLY_ thing not working properly was the MyCloud.  Go figure.

Still working this morning.

Its gone again.  I will go upstairs and reboot the router and the drive.  This is crazy.  The drive was flawless from I first bought it last year until last week.  I had had similar problem with my 2TB MyBookLive which all of a sudden seemed to have gone away.  So now instead of the 2TB, the 3TB is giving me fits.  PITA because I have to move a 65" DLP TY and stand to get behind to access it as the stand/tv are diaginal in a corner between bookshelves.

Is the drive automatically updating its firmware and is the new firmware the problem? 

Look on the front page of the web ui ( http://wdmycloud.local/)) and see what firmware it is running.

I don’t think “drive disappearing” is a reported 4.x firmware issue.

some people have reported this when using DHCP and a change to static IP fixed it.

Just be sure to use an open IP and stay outside of the DHCP address pool.

When it is off the network what are the 3 lights doing? front and 2 by the ethernet cable

Tells me that Safari cannot connect to the server.  If I click “Connect As” in Finder I get a pop up saying there was a problem connecting to the server WDMyCloud, and that the server may not exist or it is unavailable at this time.  Check the server name or IP address, check your network connection, and then try again.

As for changing from one kind of IP address to another, thats a little beyond this old fart’s pay grade LOL.  Tell me how to do it and I’ll try.  But first I will try the power down, power up routine, then maybe I can check the firmware.  I do know my network is working fine, as once again… everything else that is hard wired or wireless is working including our iPads, iMacs, Network to DVD player, and of course the _other_ WD NAS drive.

Edit:  OK, the drive LED was solid red.  I unplugged it and waited about a minute, then plugged it back in.  The LED was Orange (not white) solid… and then after about a minute it started flashing Orange.  Waiting back here downstairs to see if it comes back online.

see page 10 of the user manual for LED indications

RED could be extremly hot, the the unit vertical on a hard surface and the top not covered? or it could be worse.

the orange you are seeing is probably what WD calls yellow

what are the LEDs on the back by the LAN cable doing?

Its back up and running again.  My firmware is:  04.00.00-607 and it reports as up to date.  The unit is sitting out in the open on my sub-woofer box behind the TV.  There is noting over it but 6 feet of space to the ceiling, the Airport Extreme router is about 12" away sitting on the same sub-woofer.  Maybe I should move the drive away from the sub?

it is possiable to get enterference between devices, not as common as it used to be

it could be the sub, TV or the router. the sub & TV you can turn off and see if it helps or only happens while they are on