MyCloud 3TB serious compatibility problems with MAC OS X 10.10.5

Installed it a 4-5 days ago. Have configured some restricted folders and users. Have installed all available software including MyCloud, QuickView, etc. Have configured Static IP. Is connected through Gigabit to the router. Problems :

  1. Quickview doesn’t show the drive. Showed it initially, then stopped. I also did a factory reset, still the problem remains.

  2. Finder rarely shows the drive and folders. I select ‘connect as’ and login. Takes time but sometimes shows the folders I have access to. ‘Public’ is the only one visible, mostly. When I run the My Cloud app, Finder suddenly shows the drives, but sometimes disappears also.

  3. TimeMachine is configured as guest. It is unable to locate the disk. I forcefully access the drives through Finder / My Cloud and then run TimeMachine backup. It works!

  4. Transferring files also stops midway. Suddenly the drives disappear.

Have tried factory reset. Have tried removing password protected users. Have tried a lot of combinations through the Dashboard. It seems MAC has a serious issue in recognising the drives on it’s own. It’s very unstable and quite a pain.

Was using Mavericks. Upgraded to Yosemite. No imporvement. My Windows 10 Laptop and PS3 have no problem accessing the drives through WiFi. Even DLNA access works fine through PS3. I have transferred GBs of data from the Laptop without any problem!

Is my money wasted?

Hello, welcome to the community.

Have you tried mapping the drive manually to the computer? Check  this link and try it.

Same problem here mate. 

I’ve posted similar messages, etc with no successful resolution.

What you can do is ssh into the NAS, disable a whole bunch of things, etc. But you’re only going to see minor improvements.

But ain’t it strange, Windows + other devices access the drive fine. All my Windows VMs from my Mac access it perfectly. 

For me, it was a lesson in trying out a non apple product. Next time I’ll buy the Apple TimeMachine. It will cost more but at least I’ll be guaranteed it will work as described.

If you’re within the return period, I’d be returning the drive ASAP.

Money wasted? No. You might waste some time though and get some headaches courtesy of Apple

Want to waste more money? Buy the Time Machine Capsule. Less wasted time and less headaches.


This has nothing to do with WD, Windows or anything you might want to call it. It is Apple, they are infamous for not playing well with others, if you know what I mean. This particular issue applies to SMB in particular and has been around for a while.

At least as far as I know… Search in the internet about “10.10.5 SMB issues” and you will see. Here is one…

I use 10.8.5 and to connect to MBL I do exactly as in the link provided earlier:

  • Finder

  • Go

  • Connect to server

  • I type “smb://”. Replace it with your IP. If that works, you might be able to add it to connect at startup as well.