3TB My book live shows red LED- no connection

Hey all, I’m hoping you can help.  I did a quick search but couldn’t find this exact problem.  I had a cable guy come to fix my internet modem and when he left my drive showed a red LED instead of the normal blue flashing one.  I could not get into the mapped drive (it showed disconnected) and my wife is freaking out as it has over 1TB of photos she took of our kids and now she can’t get to them.

I spoke with WD support and they are willing to replace the drive but I would have to pay to have the data restored.  Is there a safe way to get into the drive and restore the data?  I looked at the -Unbrick- posts and while I may have to do that, I would rather ask first and see if there is another option.

On a related note, it seems that these devices go bad frequently (at least that’s what it seems looking at google) for a device that is supposed to be used as a backup solution.  Can anyone tell me if there is a more stable platform I can use to protect my wife’s memories? 


Network attached with ethernet cable directly to my cable modem. 

Shared on three Windows PC’s through windows mapping.

Troubleshooting steps-

tried different patch cables

different ports

plugged directly into PC

called WD tech support and was told they could send one out on recept of bad one, or I could put a $175.00 hold on my credit card to send one out.



Hello  Slippery,

Please see your personal messages.

Hi all…I checked my messages and someone said they would call but I still have not gotten a call.  this was a month ago and so I figured I would remind you all.  My unit is still not working.  Thanks

Hi Slippery,
I just saw your request and I add the same problem since 1 week. Are you successfully resolved your problem and if yes, how?