Yet another WD30EZRX Caviar Green 3TB (External HDD) only shows 749GB

Sorry to inflame you guys with yet another noob question.

I use win XP 32 bit. I understand that I only can see max 2TB. However this won’t show 2TB.  The disk management only shows as 749GB.
Tried the HDD on some other PCs with win Xp 32 bit, and  all shows only 749GB.

Have also tried possible solutions posted here and anywhere else to no avail. (diskpart —>clean etc). I can’t install Intel® Rapid Storage Technology (not compatible with the hardware and AHCI mode not enabled anyway).

Is there any other way? why only see 749GB, not 2TB? Is it because this HDD is too advanced for my hardware and my win XP sp-3? I have updated the bios, chipset.

a year ago i bought a 2TB external HDD (WD20EARS) and the same OS recognises it as 2TB in the disk management. Why not this time with WD30EZRX ?

can you try partitioning the drive in two partitions since xp only recognize 2.2 TB


the problem is that windows’ disk management tool only sees it as 749GB. So I only can partition it max 749GB.

I have tried to format in windows 7 (MBR and formatted it as 2TB), but when I connect the external harddisk to win xp 32 bit, disk management again only sees it as 749GB.

Is my system too old for this particular Hard Disk?

I also have used the partition wizard home edition. It can see 2TB and can partition it, however the program always crashes during formatting. So no joy either.  

ops sorry, partition wizard program can see 2TB but each time i tried to partition it, it alwasy reverts back to unallocated.

tried to partition 1TB also no success.

The limitation appears to be in the firmware within your enclosure. I hope my explanation in the following thread will clear this up for you:

BTW, WD’s 3TB external My Books are compatible with Windows XP out of the box. The reason is that WD configures the external devices with 4KB LBAs rather than the traditional 512-bytes of older enclosures (such as yours?).

thanks for the reply.

I have actually mounted the HDD directly to the motherboard and windows disk management still see it 746GB. I tried in several motherboards, one of them is intel DZ68ZV with the latest BIOS. The BIOS sees it 3TB. I also tried on different enclosure.

this has driven me mad.

ISTM that your existing driver is limiting you to 32-bits. You need Intel’s RST driver (and AHCI mode), but you say that this is incompatible with your hardware.

I don’t know what you can do to see the full 3TB, but if all else fails, and if you are happy with a 2TiB capacity, then you could truncate your drive using a tool such as HDAT2. This procedure is reversible, BTW.

A better alternative may be to edit the MBR in sector 0 and create a partition table by hand. This will still only give you a single 2TiB partition, and Windows Disk Management will still complain that it only sees 746GiB, but I believe it should work.

If you would like to take this approach (it’s relatively easy), then you will need to show us the contents of sector 0.

To this end, could you upload the output from Microsoft’s Sector Inspector?

Extract the above archive to the one folder and execute the SIrun.bat file. The procedure will generate a report file named SIout.txt.

Intel’s web site has 32-bit and 64-bit Win XP Rapid Storage Technology drivers (Version for your DZ68ZV mainboard:〈=eng

I bought 5 WD30EZRX and actually don’t mind to only use the 2 TB out of 3TB. Bt since it has been difficult to get the 2TB, I consider to return and swap with the 2TB ones.

the DZ68ZV motherboard is the newest system i have but i will need to use the hard disk on older PCs as well, and I believe my older PCs cannot install RTS. All of the win XP on my PCs were installed in IDE mode thus ACHI is not enabled.

I will let you know if I will go with the editing the MBR.

Thanks for your help.

if I edit the MBR and create a single 2TB partition, will the Windows Explorer sees it as 2TB or still 746GB?

I can’t answer your question, but what I’m proposing should tell us beyond doubt whether a 2TiB partition on a 3TB drive is a workable proposition in your case.

If I could explain what I wish to do in decimal terms, perhaps it will be easier to understand. Let’s assume we have a hypothetical PC that cannot handle a HDD with more than 1000 sectors. In other words, its number system is limiting the total number of sectors to the range from 000 to 999. If the drive has a capacity of 1749 sectors, say, then the OS sees only the lower three decimal digits, so it thinks that the drive’s size is only 749 sectors. Therefore, even though the OS is capable of accessing sector 999, it will not attempt to create a partition of that size. I’m proposing to create such a partition by manually inputting the 1000 sectors in the partition table in sector 0. I’m then hoping that the OS will be happy to accept the data in sector 0 in preference to its own “knowledge” of the drive’s capacity.

ISTM that you may have already tried to do this with other partitioning utilities, but it’s hard to know exactly what was done. If we can see the actual bytes, then we can be certain that we are doing what we think we are.

If the above fails, then we can use a utility such as HDAT2 to cut the drive’s capacity. The drive will then report that it has 1000 sectors rather than 1749 (2TiB instead of 3TB). Windows XP should then have no problem with it.

thanks for the explanation.

I wonder why when I formated it using Win 7 OS from my laptop, it won’t be recognised by win XP? I formatted it as 1TB, and also try 2TB under win 7, but when connected to win xp it says the drive is not formatted?

I can’t answer your question conclusively without examining the partition table and boot sector.

Did you use GPT or MBR partitioning? Win XP doesn’t understand GPT.

I formatted as MBR.

I guess I cannot inspect the partition table now as I have packed the drive back, ready to be shipped back to the shop.

My friend brought a 3 TB HDD (Seagate FreeAgent GoFlex) and it is recognised straight away as a 3TB HDD in all of our PCs running win xp 32 bit.

How can this happen?

Seagate’s 3TB GoFlex external drives, and WD’s 3TB externals, are both USB mass storage devices rather than hard drives, at least as far as Windows is concerned. Therefore they are accessed via a SCSI-like command set rather than ATA. USB mass storage devices use a different driver, but more importantly, the USB-SATA bridge firmware inside the enclosure is configured for 4KB LBAs rather than 512-bytes. The maximum size of an MBR partition is 2^32 LBAs (ie the largest number than can be represented in 32 bits). For 512-byte LBAs, such as those used by internal HDDs, this works out to a capacity limit of 2TiB.

However, for 4KB LBAs, the capacity limit for MBR partitions now becomes 16TiB rather than 2TiB. This means that Windows XP can access these external HDDs straight out of the box. OTOH, those third party enclosures whose firmware is configured for 512-byte LBAs will still be stuck at the 2TiB limit, and will still report a capacity of 746GiB.

You should be able to determine the logical and physical sector sizes using the following command line:

fsutil fsinfo ntfsinfo

So if I can find an enclosure which is configured for 4KB LBAs, will this solve my problem with WD30EZRX ?

I can’t answer your question, but there was a recent thread where a user replaced a 3TB WD drive in a WD enclosure with a 1TB WD drive, and then needed SmartWare to format it. It could be that you will have similar problems with a third party enclosure, in which case the question will be whether you could still use SmartWare to do the formatting and partitioning.