WDC WD30EZRX-00MMMB0 3 TB Cavier Green, BIOS and Windows only sees 746 GB

I recently had this drive installed as a data disk on a Win7 Pro machine which recognized its full capacity. I recently installed Windows Server 2008, and as far as I remember it wasn’t untill I ran Server Backup that I noticed the drive only showing 746 GB. I’ve been reading numerous forums that have not addressed my issue. I am running a RAID 0 config and this disk is not a member, only used as a data drive. I can’t tell if this is an driver or BIOS issue. Any help appreciated!

Is probable that you need to update the Bios, if that doesn’t work you might need to install a controller card that can handle a 3TB hard drive.

As Alucard mention I think you will need a controller card that handles 3 TB drives…

eezduzit, you need to refer to this earlier thread–


I was struggling with this problem earlier on with a Sandy Bridge ITX board (check here, review even uses this drive) that supposedly supports 3TB. SATA was set to AHCI. Drive was partitioned into GPT (due to MBR’s limitation). I was trying to use it as a boot volume, and had it partitioned into 3. The biggest partition being 2TB.

When Windows (64-bit) finished installation and rebooted, I couldn’t see the 2TB partition. I tried a varieties of different ways, and it just wouldn’t work. Someone mentioned a new Intel Rapid Storage driver would fix it. Got that (ver It failed.

Now, why didn’t I try using the supplied PCI SATA card? Well, because I only have 1 PCI-e slot on this board. And because I read someone else’s post that said Windows 7 (especially the 64-bit version) doesn’t have a 3TB limit. I don’t know if I want to believe that. Because… Well, read on.

Out of frustration, I booted up OS X installer disc (big thanks to Tonymacx86 forum), and installed the OS into the drive. Eureka. the 2TB partition, along with the other 2 partitions showed up, all beautifully working in OS X 10.7. And this is now being used in the Hackintosh machine. One of the partitions contain Windows 7 64-bit. Sadly, once booted into that drive, the 2TB is still gone. Whereas on OS X all partitions are showing up correctly, Disk Management on Windows 7 insists on showing a 2TB and 746.52GB unallocated partitions.

So I’m stuck running OS X for primary functions, and only switches to Windows for games. Not that I game much these days.

For what it’s worth, before I installed OS X, I also tried out Windows 8. There wasn’t any issue with 2TB and unusable 746.52GB partition. But the OS seems like a super-sized Windows Media Center, (which is the first component on Windows I steadfastly remove) so it just doesn’t work for me.