Advice needed - 3tb WDC EZRZ-00Z5HB0 hard drive only showing 746gb

I am trying to install a new 3Tb WD Blue hard drive as a data drive not a boot drive and have found that it only shows as 764Gb, but I can’t seem to get it to show the full capacity.
The drive is set as GPT and I have also tried it formatted in NTSF but with no success. It only shows as 800Gb in the BIOS too. Please can anyone help me to resolve this.
My PC spec is as follows -
Model: HP Pavilion p6310uk
Motherboard M2N68-LA (Narra6)
Processor AMD Athlon II x4 630 2.8GHz
RAM 4Gb (PC3-10600 MB/sec)
Hard Drive(s) 1Tb (main) WDC EADS-65M2BX SATA, 2Tb (data) WDC EZRX-00DC0B0 SATA, and 3Tb (data) WDC EZRZ-00Z5HB0 SATA (the one I am trying to install)
Graphics card NVIDIA GeForce G210
Operating System Windows 7 Home Premium with SP1

As I have an AMD processor I am guessing that the Intel RST solution suggested on the web won’t work. My ATA controllers are NVIDIA nForce serial ATA controllers. I am at a loss as to how to resolve the problem, so any advice would be most welcome.
Many thanks in advance

Hi Adrian,

Looks like this is due to the limitation of your BIOS, I suggest to find out if you can find any updates for the BIOS to solve this. Another option you could try is to download the gParted CD-ROM and split the drive in smaller partitions, not sure if that’s what you want…

I believe WD had a program for this but no idea if it still exist.

Last resort is to buy a pci sata controller what can handle such huge drives.

Thanks for your reply RK,

I have checked the BIOS version and I have the latest available from the motherboard manufacturers. Looks like I will have to go down the Gparted route as I don’t have any spare card slots available to fit a pci sata controller.

I have fitted hard drives up to 2Tb capacity before with no problem, but didn’t think a 3Tb would be so much hassle!

I used Gparted to create two partions of 1.81Tb & 938.91Gb which was my initial intention for the drive and, although it shows fine in Gparted the PC now hangs on startup and will only boot if I disconnect the SATA cable from the drive.
The BIOS is still showing it as 800GB though.

Looks like I will have to e-mail Asus as the BIOS doesn’t want to play ball, despite being the latest version.

Is this the only drive in your PC, I had the impression you added it?
Make sure when you use gParted you make the fist partition bootable, format ntfs and make it 500GB and split the rest up in 2 other partitions, so you have 3 partitions in total.

That might solve the boot issue.

Just wondering about your 1TB and 2TB drives, can you use those as they are, or did you split those up as well?

  • Try it with only the new 3TB drive on the master sata cable with previous mentioned new partition scheme and remove the 2 others [unplug their power and sata cable]

Just ignore the BIOS, we are trying to fool it…

Hi RK,
Yes this is an additional drive.
Originally the PC came with a 1Tb drive which I divided into 2 partitions - one of 332Gb which is the boot drive containing Win7, another partition of 585Gb for a general data drive.
I later added the 2Tb drive (which was accepted as 2TB without any problem), and I partitioned this drive down into 2 partitions each of 931Gb to act as to separate archive drives for storage.

This 3Tb drive is another additional drive that I had hoped to use in larger partitions as it would better suit my needs, but I may have to patition it into more, smaller ones as you suggest if that is the only way it will work. I have managed to free up a card slot so I have ordered a SATA controller card to give that a try when it arrives.


Because you use the RED as a ‘normal’ drive you better check and turn the TLER off.
Perhaps it might also be a good plan to disable the idle3, unless you want to end up with a very high LLC in your SMART and avoid UN-necessary wear and tear.

I think this is now moving into areas beyond my level of experience. I have read the PDF and think I understand about TLER, but how do I access TLER to turn it off. Does this need to be done on the boot drive, the slave drive or all?
Also, where do I find the ‘disable idle3’ function and again, is this for boot drive, slave drives or all?
Sorry to be a pain but this is new territory for me.

I understand, if you Google about idle3 and tler you will find out why it is necessary to turn it off or on.
I mentioned it because noticed you have all WD drives and so to say in all ‘colours’ blue, black, green, there is this power saving option, but if you use your drives in a PC it is defeating the purpose, also it wears your drive down for nothing. I expect many drives failing because they are over the 200K [LLC counter] Also RED is meant to be used in a RAID / NAS configuration there for you better turn it off in a PC.

Please do read up and if you can’t find the programs from a reliable source, then PM me.

P.S. I think the ultimatebootcd has the idle3 on board:
Check your SMART data for each drive and make a note of the LLC counter.

I found a nice article what explains the usage of the TLER setting in WD drives.

I had an e-mail back from ASUS yesterday which confirmed that my motherboard is not capable of supporting hard drives in excess of 2Tb.
However, my new SATA controller card arrived this morning and once fitted to the PC and the 3Tb drive connected, ‘hey-presto’ the drive works perfectly, so as you suggested, in the end this was the solution to solving the problem.

Many thanks for all of your help RK, and I will continue to read up on TLER, idle3 and LLC. I think I am starting to get my head round it now.

Best regards,

Thanks for the feedback Adrian, glad all sorted with your new HD.