Workgroup Name = solution for network shares issue, is no longer working

Like most everyone else here I have always had torubles connecting the hub to simple network shares on my windows network. Previoulsy I stumbled on to a fix tht worked every time. I would rename my Workgorup on my windows machine, then rename it back to the original name and viola…the hub would find the share every time.

Seem since the last firmware update it has taken this solution away.

Suggestions please?


PS, I have read most every tutorial regarding MS browser and advanced sharing settings anf they are all correct. I can provide screen shots if necessary.

Well, your “fix” actually highlights an issue. 

All that Windows is doing when you change workgroup names is that it rejoins the workgroup.  (Well, that and the two reboots that it forces you to do…)

So it sounds like your workgroup is unstable.

You said you’ve read a lot of the tutorials on MS Browser, I don’t know if you have read this one:

Do this when it is NOT working.

Thank you Tony, I know your toutorial like the back of my hand(thank you for that btw).

Take a peak and tell me if I’m missing something. Sometimes after doing something over and over and over, it becomes easier to miss. :stuck_out_tongue:

Is, indeed, the computer named TNA the ONLY computer in the workgroup that’s sharing?

Yes that is correct. Just 1 Server. 2 Laptops but they weren’t booted at the time.

Shouldn’t I see the WD there too? I can see it fine in explorer and I can ping it.

If you have SHARING ENABLED on the WDTV, then yes, it should appear there, too.

It does.


So your screenshot does NOT include the WD, but you say that it DOES appear in the list now? What’d you change?

the subnet on the WD was set to instead of

so it’s in the list now. But it STILL can not see the server.

Ok, now try the command

net view tna

Sorry for the long delay in response.

UPDATE…for what it’s worth. Same thing is happening. Took the WD with me when I went out of town. Came back, it could not find the server. Change the workgroup on the server, then changed it back(all w/out rebooting). Viola…the WD finds the server.