WD Live hub does not see shares in AD 2008 Network

I’m running an AD 2008 Network and the WD Live Hub does not even see that there are shares. I have edited the workgroup setting to match my domain (which is where I think the issue lies, since it says workgroup and not domain).  I have tried sharing the media files to Everyone (even enabled  the Guest account), and restarted the WD each time I made the changes and it still didn’t see the shares, doesn’t even see any shared files/folders/machines.

I’ve seen posts about domain credentials, but none of them reference how to even get to that point.

So how the heck do I get the shares to show?

Does the device even work in an domain environment??

Well, it doesn’t say on the box or the user manual that it supports any version of Windows Server…

ummm but it does support smb, which is the way the Windows shares files. All the device needs to do is talk to the server,  network share is a network share.


I had exactly the same problem. I have configuration with W2K8R2 as a server (AD, dhcp, dns e.t.c.)

Actually it still doesn’t work as it suppose to. Support was not helpful anyway. They don’t know how it’s enumerating devices in local network or how it’s filtering  devices.

  1. do not use dhcp. When you using it, device picking up domain name prefix and ignoring specified workgroup name (You can see it in Web UI network parameters page).

  2. To have it working, i configured another pc in my network to be in same group and configured domain prefix (by some reason it’s important for this device). Now i can see both PC’s (W2K8, W7) but if i’m turning off W7 they both dissapearing from list.

Thank you, and I got the same response from WD support.

I’m not use the AD server for DHCP, just as a DC and to push out shares.

I have the ‘workgroup’ listing in the HUB to be my home domain

I also have Upnp enabled as well as Netbios, and SSDP. I even enabled anonymous logins on the device.

The Box won’t even see the Server, much less the shares.

I was going to just add a host as a VM to the Server and have it share out the shares, but I’ve seen several instances where people got it working in a similar environment. So I don’t want to go that route, but it’s starting to look like it is. I have a linux machine on my network that isn’t part of the domain so trying with that one is next. If that works then I’ll set up the VM.