"Windows cannot access \\MYBOOKLIVEDUO"; green light flashing, then enters standby

Hi all,

my MyBookLiveDuo worked fine for over a year. I do not keep it running all that often and have it unplugged most of the time, but when I now restarted it, I was unable to access it.

I can see it in my network as “MYBOOKLIVEDUO”, but when I try to access it using Windows Explorer, Windows (after a while) tells me that “Windows cannot access \MYBOOKLIVEDUO”.

The little WD QuickView tool cannot see the drive at all.

When I restart the drive, the light flashes yellow (as expected), then flashes green for quite a while very rhytmically and with lots of HDD activity, then goes solid green, and after a while turns solid blue.

I restarted the drive a few times now already, but I still cannot access the drive.

Any thoughts? I am getting really worried about my data…



PS: I have exactly the same problem when I use a network cable to directly connect my laptop with the drive

Most likely you have a problem with your Windows PC. Something in the registry.  Try using a PC or Mac which has never been connected to your MBLD before.  If that doesn’t work, then you can assume that something is wrong with the SMB server on teh MBLD.  Can you access the Dashboard?  If so, enable SSH.  Then login with Putty and do a Samba server restart. 

Just re-tried connecting directly to the drive, and it works via network cable…

Your problem is not with the MBL. The problem is with your PC.  It’s some registry issue.  Try using another computer.

Sorry for getting back so late, was on a business trip. It works with another computer indeed, so it seems like the MyBook Duo is fine.

Any thoughts on how to fix my registry issue then?

Try unmapping it from your Windows PC.  Then go to Network and you should see the MBLD listed.

Then remap it or just go into the Network route going forward.

Bizzarely enough it just worked again. I did not explicitly unmap anything, but it now seems to work again.

Maybe restarting the computer was enough…anyway, sorry to bother all of you with a problem that solved itself…