Windows 7 won't give me option to eject WD My Passport Ultra 1TB

Hello, I did a clean install of Windows 7 for my new PC. I purchased WD My Passport Ultra 1TB Classic Black to use as my back up. I created two partitions, and backed up my computer. Then I wanted to eject the WD My Passport, but when I right clicked on the drive, there was not option to Eject. There is not Icon on the bottom right side either. I did some research and others said to run:

RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll

I did this and then the option at least came to click to remove it. I did so, but then the error message said: "the Unit WD SES Device is not portable, and cannot be removed, or disconnected. (This is my translation from Norwegian to English)

The only option to disconnect the WD is to turn off the computer and then disconnect it… but there has to be something else I can do? I installed the drivers available on the WD support website, but that still didn’t help…

Thanks for any assistence!

You should have the “Safely Remove Hardware and Eject Media” icon in the systray on the right hand side of the taskbar (near the clock) when any USB drive is connected (it looks like a USB plug with a white tick in a green circle - you may need to use the “Show Hidden Icons” up-arrow if you have that feature active).

If you click on this it should give you a list of connected drives, and you can click on items in that list to stop/eject them. Note that if any program or service has a file open on that drive (including backup) or is accessing it then you won’t be able to stop and eject the drive.

Alternatively install WD drive utilities (quickview) and it will give you the option via its right-click menu to safely remove a MyPassport.

If DarerenHill’s suggestion doesn’t work, you can try this: If you do Ctrl-Alt-Delete, Select Start Task Manager, then click the Processes tab, scroll to the bottom. There may be one or more process labeled WDxxxxxxxxx. One of those may have you Ultra “in use”.  If you right click and “End Process”, ONE AT A TIME, then try the Safely Remove for each process you end, until you learn which one (or combination) frees your My Pasport.

Thank you Darren. Windows 10 does not give an eject option for my Passport 1T drive when you right click on the drive. I didn’t know about the icon in the bottom right area, the drive is listed there and it does do a safe eject. Thanks again.

You’re welcome.

In Windows 10 the icon looks a little different, but the functionality is the same.

Posted on this thread already How can i "Safely Remove" My Passport Ultra from my PC?

I have to say I have the same issue as well. This is with the new 4TB My Passport (2016/17 version). I have:

  1. turned off my sophos antivirus,
  2. manually closed the WD application tasks from task manager (WD utilities and WD security was running in the background),
  3. Closed off all toolbar WD applications - namely the WD Backup toolbar tray icon which always appear on startup,
  4. and unindexed the whole tb drive itself.

These were all done to no success. I don’t recognise the run methods for the dll files or what to do once I have actually opened those files from any of the forum threads before. Does anyone know what to do with the dll files in hopes that this would help solve the situation? Better yet have a fix-all solution? Thanks!

Lol, went trawling the internet looking for a solution to my problem again and came back to my post from nearly a year ago. I might just circle back here again come next year with there being no solution.

I have been having the same problem with both the 1 TB my passport purchased about 4 years ago, and also with a new 4 TB my passport purchased yesterday. This is after using the windows backup program. I tried killing WD processes one at a time to no avail. In desperation, I restarted my windows 7 computer. Obviously that killed all processes and after the restart I could then safely eject the drive. An extreme solution to the problem, but in absence of an alternative work-around, I’ll keep doing this.

not open