Windows 10 Update; KB3124263 may fix SMB issues

#1

Today Microsoft issued update KB3124263 and miraculously my WDMyCloud has reappeared under Network! Have a look at this clip from my system and see what’s showing under Network.

Is this actually a fix? Time will tell.

Paul


My Cloud doesn't appear as a PC under Network anymore?
Compilation of Windows 10 Methods, Steps and Solutions
Compilation of Windows 10 Methods, Steps and Solutions
#2

Maybe. Based upon a post you and I both saw, the other day Gramps posted a comment from a Microsoft programmer that indicated they knew of the problem and were working on it.

#3

We are nearly 24 hours into the ‘new’ update and everything is solid green! Access to the WDMyCloud is fast and it is still showing in Network.

Not saying that MS won’t screw it up again with another update. :anguished:

Paul

#4

Still broken for me.

#5

Did you get that Windows 10 update? From what I’ve read that update didn’t specifically mention SMB issues fixed, and yet it totally fixed my missing WDMyCloud and other SMB/NetBIOS problems (like “computer is missing one or more protocols…”)

Unless Windows 10 is self healing… hummm ?

Paul

#6

Can also confirm that KB3124263 seems to have solved/fixed the Windows File Explorer missing My Cloud entry under Computer and showing it under Network that I was experiencing on one Windows 10 PC. Not sure what in KB3124263 fixed the issue as that MS KB article doesn’t appear to mention anything obvious that would seem to point to SMB or similar problems.

Pre KB3124263:

Post KB3124263:

#7

Not sure KB3124263 fixed the problem My system has the fix. But sometimes when I open the file explorer. Only my laptop computer shows up under computer. But if I click on the refresh icon. Everything shows up.

RAC

#8

UPDATE

My Windows 10 has done it again. Now nothing shows under [Network]. Nothing, nada. I checked the updates and there have been no updates to Win 10 since KB3124263. I am mystified. I’ve probably spent 10 hours combing the Microsoft sites for technical details about Win 10’s interface to the LAN. Not a lot of info out there.

However, on a positive note the network seems to be running fine and speeds are still acceptable.

However I did run across one technical item during the many hours of reading the Microsoft Win 10 forums; this from a Microsoft SE who said “Windows 10 now uses IPv6 on the LAN for discovery and communication”. Wow!!! That is bad news for those still running old(er) routers and switches. In my case I do have IPv6 active on all Windows 10 boxes and both of my routers/gateways are IPv6 enabled but I’m not sure about my switches. Interesting.

More research to do.

Paul

#9

Morden2004, funny you say that. Same thing happened to me. It started happening Thursday on my Windows 10 test bed. That computer worked for almost a week post KB3124263 showing the My Cloud under Computer in Network, now it doesn’t. Nothing appears to have been updated by Windows since the KB3124263. Mapped shares still work. Not sure what to make of it other than MS strikes again.

#10

Mine went south on Thursday too! That pretty much confirms my thoughts about this ‘new’ update policy of Microsoft. I may go back to running O&O to shut off all access to my systems. I’m po’d and more.

Paul

#11

Well, this situation with Microsoft 10 network SMB (?) issues is so inconsistent that I fail to see where we’ll ever get a fix for the systems that are affected. Why? Because my #3 desktop system, which has KB3124263 applied (Jan 14th), has all the network object display in [Network]. That system is an older** Intel LGA775 Core2Quad** processor. The main system, which has nothing whatsoever showing in [Network] is an Intel I7-3990K processor.

Paul (very discouraged)

#12

What are your network adapter properties? Lately my network has always shown the network data. Here is my network properties and output from file explorer.

RAC

#13

The network settings are all the same. There seems to be some issue regarding either how the updates are installed -or- in what order they are installed -or- other differences between the various computer hardware configurations. Very odd.

I have also tried different File Explorers and they all show the same [empty] network.

Paul

#14

When you open windows file explorer. Click on the network. Then if nothing shows up. Click on the refresh icon. This should cause every thing to appear.

RAC

#15

Not necessarily. My Win 10 test bed no longer populates the My Cloud under Computer when hitting the refresh button. If I perform the SMB fix then the My Cloud shows up. If I plug in the IP address the My Cloud shows up. I’ve learned to live with it for now.

There is something wonky with Windows 10 as this problem is not necessarily confined to the My Cloud, other NAS users using other brands/models are having troubles with Windows 10 as well.

#16

Windows 10 is the worst version that I’ve ever work with. Its been 6 months and I still can’t get my PC to do the things it did before the upgrade to windows 10. By the way I was having the same problem with things not showing up in computer or network. But now every time I open the file explorer all my network devices show up under network.

RAC

#17

Everyone has a different take on new software releases.

Having lived with every Windows release from the very first one, I can honestly say that Microsoft have done a credible job on Windows 10. Perfect? No. Pleasant to use? Yes. Best operating system ever? No. (I still remember early releases of IBM’s mainframe operating systems way back in the late 60’s - now that was fun).

Windows 10 is not for everyone, but I like it.

Paul

#18

Well for the first 5 months. Every time I would wake up the computers they would blue screen. Once they rebooted they would run until the next time I put them to sleep. Until today none of the computers running windows 10 would not wake up to run any scheduled tasks. My primary
purpose of these machines is to act as DVR’s. But you had to go to the machines to wake them up to start the recording. Of course you had to do it early because over half the time they would blue screen on wake up. None of the house keeping tasks that I used to run would run. I found out if you use the c:\windows\system32\rundll32.exe powrprof.dll SetSuspendState 0,1,0
in a powershell script it would sleep but not wake up. I even tried psshutdown -d -t 0. this also would put the system to sleep but it would not wake up. I finally today wrote some code in powershell to move the mouse to the start menu. Left mouse button click. Then move the mouse to the power and left button click. Finally move the mouse to the sleep and leftbutton click. This puts the computer to sleep and it does wake up to run tasks. There are other glitches but I can live with them. I spent days googling looking for a fix to these problems. Never found an answer.

RAC

PS I missed your reference to the 60’s IBM mainframes. I worked with the Burroughs B5500 mainframe OS. Yes they were fun.

#19

rac8006:

How old (or new) are your PC’s?

Paul

PS: Yes, I spent a few fun years at IBM Canada incl. working on software in Poughkeepsie NY after I switched from hardware engineering. Fun years.

#20

Both PC’s were built in Sept of 2010.

RAC

PS: I also was a hardware engineer trained on the B5500 mainframe,before switching to software.