Windows 10 problems - a suggestion

There are increasing numbers of people reporting problems with using the MyCloud after upgrading to Windows 10, when they previously had no problems with earlier versions.

Since the common theme appears to be Windows 10, can I suggest that, if you ask about the problem here, you also report the problem to Microsoft, since it seems to be their operating system that is causing the problems.

I’m not saying that the MyCloud is perfect (far from it) but let’s be realistic about where these problems are most likely to lie…


I have windows 10 on one of my computers and have no issues with My NAS devices, however its a good advice to contact MS since there might be some settings that have to be done perhaps. 

Same here Windows 10 on a test bed PC generally no problems accessing the WD My Cloud locally. One issue that did crop up which has been discussed elsewhere is Microsoft removing the DLNA client from the new music app in Windows 10 (not Windows Media Player).

One common complain I’ve noticed with Windows 10 complaints is that sometimes the upgrade to Windows 10 corrupts or changes the network settings including changing the firewall and NETBIOS settings so one can no longer view local devices on their local network.

I’d go one step further and ask that people also include the information of how did they upgrade to Windows 10. Was it an upgrade in place over the top of an existing Windows OS and if so which one? Or was it a fresh install on a hard drive that didn’t have a Windows OS installed or was the Windows 10 forced fresh install that wipes out the existing version of Windows 10 and takes it back to bare bones?

I have this problem and is really affecting my work. I had Windows 8 on the lapop previously and I have updated to Windows 10. I can see everything using the WD software but can’t see the cloud on the network.

I have tried a lot of things that I have seen on the internet but none worked.

One issue to check is to ensure Windows 10 hasn’t configured the “network location” as “Public” which can potentially block access to many or all local network devices. The following link gives a general explanation of how to make the setting change. Note they used a preview build of Windows 10 so the screens on your version of Windows 10 may look slightly different but the general steps should remain the same.

How to change Windows 10 network type from Public to Private

Hello all,

I have an issue on a new PC, new install of Windows 10. The install was done on the build of the machine, ie before I touched it (I’m not proficient with this stuff).

My Windows 7 machine recognised and gave me desktop and remote access to the cloud so I can manipulate the content from folder to folder. Now since introducing the Win10 machine to the MyCloud path, which it recognised and gave ne access to about a week and a half ago, now suddenly does not allow me to use my user name and password. It claims it was incorrect. Now I’ve not changed that password since I set it up and I’m the admin. Now after closing and restarting the Win7 machine this past week, it is telling me the same thing. Effectively I’m locked out of the drive through no fault of my own. The only way I can manipulate it is through the ‘portal’ I think it’s refered to as; remotely. This is no fun as I’m limited as to how I can manipulate the content. I can still see the content with my portable devices, but still, I’m not happy.

Anyone with a pointer or two for me please?

Thank you in advance.

Can you access the Dashboard?

Can you access/have you accessed the Public share?

Are you hitting the ‘Windows cannot connect to multiple network shares with different credentials’ issue?

If the password really is wrong, you can clear it with a 4-second reset. You won’t need to enter a password, and should then be able to access the Dashboard, and change your admin password.

Have you looked at this thread:

Thank you for the reply cpt_paranoia.

No I can’t access the Public.

No I’m not experiencing the ‘multple’ thing at all.

I had not even thought about the 4sec reset. Thasnk you for that. Though when I get to do that I won’t be able to get to the Dashboard as I get a 503 message at the moment when I try to access it now.

What is the exact wording of the error message you receive after inputting the user name and password? Can you post a screen shot of the message?

Couple of suggestions. For local network access to a Private Share on the My Cloud, one would use the username and password created through the My Cloud Dashboard interface. If one is accessing a remote My Cloud they would use the username and password created through the web portal. The two usernames/passwords are NOT the same.

Windows doesn’t like it when users use two different sets of usernames/passwords to access a local network device. It is a Windows problem not a My Cloud problem when this happens. The workaround is to ensure you use one username/password to access all the Private Shares one needs to access on the My Cloud. One may have to remove existing mapped Shares and existing My Cloud entries in the Windows Credentials Manager to fix the error when mapping or accessing multiple Shares using a single username/password.

Seems this system is out to get me, or at the very least make me out to be a liar. Now the Multiple message is prominant as opposed to the 'not valid one from the night before last cpt_paranoia, so you hit the nail on the head.

Not sure if the latest development has a direct correlation to what you were eluding to Brennor, but thanks for the heads up. I really was just logging on to take a screen grab of the rejection text so you had a better idea of what I was dealing with but now I’m just gonna head to bed and try the reset cpt_paranoia suggested above. It also might give enough time for your good selves or someone else to explain to me that doing that might be detrimental. Of course, if I read that in the morning I won’t, but it’s all I have atm,… the other PC can, I suppose, lose the access to the drive though now that I think of it I’d just prefer to give the rights exclusively back to it and port info to and from them using local hdd. Less stress.

Anyway, thanks for the tips and tricks so far gents, appreciated.

Shouldn’t be any need for that if you’re sure you remember the password.

What you will have to do is remove the credentials associations for the Public share. If you have it mapped, unmap it and reboot.

Then, when you map the Shares, hit the ‘connect using different credentials’ toolbox, and enter your MyCloud credentials.

If this doesn’t sort it, try the Windows Credentials Manager, and delete the credentials it has recorded for the MyCloud.

The second paragraph of your screen capture tells you the problem. As mentioned previously, Windows doesn’t like it when a user uses two or more different usernames/passwords to access a network device like the My Cloud. Its a Windows problem not a My Cloud problem. Possible solutions mentioned previously include making surre you use just one single user name and password on that computer to access all the My Cloud Shares you want to access. Access the My Cloud Dashboard > Users section to change which Private Shares a user has permission to access.

Afternoon all.

Okay I hear you guys but as I mentioned above I cannot get access to the portal or dashboard. I get a 503 connection failure on all of the connections to the drives. Less I’m missing something (probably am) I’m stuck. Do I reinstall the dash? strip the hdd connections from both machines and install fresh on the new PC? Seriously guys I really have no clue as to where to look for these ‘credentials’ you speak of. Think of me as the ■■■■■ and baby I am and point me to my bottle because I’m lost.

I hear you Bennor, but I really only use the one user name and password on both machines, no difference! It has worked fine on the Win7 PC for years, now, with the introduction of the Win10 PC it has stopped giving me access. The Win7 PC now says ‘Logon failure: unknown user name or bad password.’, in the login window. It will not let me do anything else with it, apart from try putting in the passwd again, which it just repeats the refusal.

Thanks again for your time here.

Okay; that’s new information…

I’d try a reset, then. If it has done a firmware upgrade recently, it might be a bit confused; that’s not unusual…

There’s nothing to install; the Dashboard is a web-based front end, and runs on the MyCloud, accessed via a web browser. Think of it as a website.

Credentials: user name and password

Unless you have used the same user name and password for both PC and MyCloud, Windows will object when connecting to different network shares. Even if the are identical, it may still consider them to be different credentials.

Use Windows Start menu search to find the Credentials Manager.

When trying to log on to the PC itself, or to the MyCloud?

If you cannot even access the My Cloud Dashboard, have you gone through the suggestions mentioned in the Compilation of Windows 10 Methods, Steps and Solutions link posted earlier? Those troubleshooting steps tend to fix many issues related to being unable to access the My Cloud assuming both the My Cloud and Windows computer are on the same local network.

In particular, from that link, look at steps Windows 10 Specific Method 1 through Windows 10 Specific Method 5 for the common things to check.

Gents, really appreciate you guys holding my hands here.

Okay, I’ll got through the steps as suggested Bennor.

That message appears when trying to log onto the drive via the desktop cpt. I access the drive via the network folder list under the favourites tab to the left of a windows folder. Double click and it asks for the log on ‘credentials’ (I am listening lol) the first time of a new PC session. Every time thereafter no need till I shut down and start up again.
No, my PC has its own passwd. Network MyCloud folder has its own user and Passwd.

Just looked at the credentials mgr, it shows me x3 diff network locations with d passwds I don’t recognise by length alone…

wow!! I got it working…Somehow it had reconfigured the drive passwd to the homegroup shared passwd…?!! Don’t ask me why. It certainly is not a passwd I can look at read and put in from memory leave lone use it all the time. I seem to remember some time ago I had this issue and just tried it as a hail mary…What the heck!

Map the Shares as network drives (‘Map Network Drive’ in File Explorer). Tick both ‘Re-connect at logon’ and ‘Use different credentials’ options. Enter your MyCloud user credentials. Do the same for each share.

Windows will re-connect the shares as mapped drives every time it boots.

This is by far the best way to access the MyCloud shares; they look like any other drive letter, and can be used transparently by any program.