Windows 10 can't see My Cloud workaround

I rebooted my system and the devices were not listed under network. I clicked on the network
and the devices showed up. After that they seemed to show everytime. Strange

RAC

There is potentially an SMB issue with Windows 10. I have found that changing the SMB setting either in the My Cloud or on my Windows 10 PC seems to fix the missing My Cloud in the File Explorer. Unknown how that change will affect file copying speeds though.

See the entry titled Method 6 in the following updated thread…

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

The best solution I have found for the My Cloud disappearing is to make my router the Samba Master Browser and to turn off the Computer Browser service in all networked Windows PCs to stop contention issues.

I also reset the network on a couple of troublesome PCs with netcfg -d and after a reboot of the PC the My Cloud appeared. (Use with caution.)

Which, as you pointed out in your other thread, only works if one has a router that has a Samba Master Browser option. If one’s router doesn’t have such an option they can either change the SMB2 & SMB3 settings on Windows 10 to SMB1, or change the SMB2 setting on the My Cloud via SSH to SMB1.

Edit to add: Updated the thread Compilation of Windows 10 Methods, Steps and Solutions to include the router / My Cloud Samba Master Browser fix in Suggestion for MyCloud poor responsiveness over Samba. There are now three SMB options to try.

I had the same problems detailed above. But this issue apparently has been resolved by Microsoft. As of today I can finally see Mycloud in file explorer!! Hip Hip Hurray!!

No it hasn’t. People (including myself) are still having problems even with the latest update released a day or two ago with Windows 10 not properly accessing Samba shares. See the following thread where there is current ongoing discussion on the Windows 10 problems with the My Cloud.

https://community.wd.com/t/windows-10-not-finding-network-devices-good-news/149252

And the following thread which contains a compilation of possible workarounds or fixes for Windows 10 users who experience problems with the My Cloud.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

yes i did have an issue with samba 3.1 and win 10 i decided to update to the creators build … windows now uses smb 3.1 and getting it to mount took a bit but it works although slow avg 15-20 up

i decided to let the stock settings control things i turned server smb off and set client smb on and now it is a matter of getting it faster…

just change the name of your workgroup and it will reappear
then change it back if you want ,it will stay
I been through this about 10 times already ,this is what solves my issue

How I managed to access my MyCloudEXUltra shares on Win 10.

In our office we used the WD My Cloud personal storage as internal server. It worked perfectly for two and a half years. After one of the win10 upgrades, the device began to disappear from the network. Become very slow or not available at all. So we started every working day with the restart of the device and than it works for all day. I have access to the dashboard, no issues there. I ran quick and full diagnostics tests no issues there as well.

After these issues I was concerned about overall health of the device controller so we purchased new MyCloudEX2Ultra NAS server. And then it started. We did not not see shares on the network. I tried everything I could find on support pages, nothing worked for me. The thing is that it shows under network storage devices, but not under computer and I can not access shares. I can access dashboard, no issues there, I did firmare update, created users, shares but nothing helped to access shares on windows explorer.
I could ping server IP. I have turned on network discovery, file and printer sharing. Set workgroup. Enabled NetBIOS over TCP/IP. Windows sees NAS, but can not display folders.

Solution.

I started a small program - ipscan25 (no need to install). Scan the network, all connected devices are displayed. Clicking on the MyCloud’s IP addresses can open file explorer. From there you can pin your shares to quick access. As soon as this route is specified and opened, the device appears on the file explorer network. From there you can do drive mapping for the necessary shares to my computer. Or just use quick access shortcuts on your windows. This process has to be done on every computer that needs to access the cloud.
So far, everything is working fine.

I have the same issue and am trying to find a solution now. Done all the obvious. I can map a drive but can’t browse. Must be a windows 10 setting somewhere 'cos some people seem to be able to browse with no problem. My “Network” section in explorer is empty!! Strange. Windows does seem to be fraught with these problems. Wonder why.

Hi all, sorry to pick up this old thread. I just had the very same problem with a freshly set up windows 10 box so I thought I post my solution here.

The setup is a home windows SMB network, with Win8 and Win7 on laptops and workstations, 2 file servers are running, one is Win10 and one is MC, with SMB3 enabled. Passwords are set up everywhere.

The strange thing was that MC was not visible from one of the Win10 boxes, yet visible from anywhere else in the system.

Turns out I had to enable SMB1 in “programs and features”, “SMB 1.0/CIFS File Sharing Support”.

No idea why, my expectation was that everything SMB3 would cover it all.

Hope this helps.

A recent Microsoft Windows 10 update may have disabled/turned off the SMB1/CIF option. WD has a knowledgebase article discussing how to turn the feature back on:

https://support.wdc.com/knowledgebase/answer.aspx?ID=20736

It should be noted that the reason Microsoft disabled this feature is due to security vulnerabilities. See the following Microsoft blog post. So reactivate SMB1/CIF at your own risk. One can still access and map the My Cloud using the device’s IP address or possibly the device name.

https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/

https://support.wdc.com/knowledgebase/answer.aspx?ID=2676

There is a section (method 3) in the WD Community Compilation of Windows 10 Methods, Steps and Solutions thals explains this issue.

I have a MyCloud Mirror, but having the issue where the NAS device shows on the network, but does not “open” in File Explorer (in order to map the public drive). I just switched from an older HP (running Windows10) to a Dell (running Windows10). Nothing else on my network changed.

I have the latest firmware, and, while I had the problem of the unit dropping off the network every week, at least I could hard reboot and get at the files. What now?

After Windows 10 Fall Creators Update 1709 - Microsoft turn off guest account on SMB2, SMB3.
To change, go to groupe politics (gpedit.msc)
Computer Configuration ->Administrative templates -> Network -> Lanman Workstation
Turn ON - Enable insecure guest logons
or
change in registry:
HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
“AllowInsecureGuestAuth”=dword: 1
After this, You NAS must be seen in File Explorer! :slight_smile:

Got it working, and then it failed again. Steps taken were:
Turn off SMB & reboot
Turn on SMB and reboot
Map network drive using (static) IP address

I also did what you suggested on the configuration (although I see nothing on SMB2 or 3 in Windows Features)
It worked for 24 hours; this morning neither of these fixes works. I will try killing the power on the MyCloud Mirror and start again (as I used to do). I wonder if any of the new WD drives have the same problem.

I turned off the Drive Sleep feature, and that seems to help.

@ NunyaBiznas:
Open File Explorer
In the address bar type ‘\MyCloud’ [enter]
(obviously use the name of your cloud including spaces)
When your My Cloud shows up in the left pane under Network right click on it
Select ‘Pin to Quick access’
Curse Microsoft and swear about how stupid it is you had to do this

Thank you for your tip. It works for me. For clarification, you need to type 2 backlashes before the device’s name in the File Explorer, like so:

\\WDMYCLOUD

and hit enter. It should show up under “Network”, and you should pin it to quick access.

1 Like

This worked for me many thanks. Stupid Win10 is good but a pain for NAS drives like this

I’ve got the same problem and I tried this 2-3 times with no success but then it just worked. Windows asked for the username and password before giving me access (just once) but now I can get at my files.
So try it a few times.
Thanks

Do you guys ever find a solution? Same problem here and I have tried EVERYTHING!