What to do to extract data on HD when PCB fails and cant find a replacement with exact model/Rev. number

I have a 4TB Myclud with a broken PCB model 4061-705144-001 Rev.02P.
I just need to extract my data from the hard drive.

I tried to look for a PCB replacement but couldn’t find one with exact mach for the Rev. number. I’m told if the Rev. number doesn’t match then swapping the PCB wouldn’t work. Can anybody please help me? what options do I have in this case?

Generally the single bay My Cloud drives are formatted for Linux. One can either use a Linux PC to access the drive contents (using a USB to SATA adapter or a spare SATA port on their PC) or use a third party Linux driver that will allow Windows to read the contents of the My Cloud hard drive. There are a number of past discussions (that can be found using the forum search feature, magnifying glass icon upper right) that discuss how to access the My Cloud hard drive when it is removed from the My Cloud enclosure. Here is one such discussion.

this is true. (EXT4 from memory)

but NOT if the PCB is broken or has failed … as the OP has written.

Without a functioning PCB/Logic Board Controller for the Hard Drive … it’s a Paper Weight.

Ah your right. I miss-interpreted the PCB to be the My Cloud back plain or motherboard. Yeah if the board on the drive itself is bad or defective then it is very bad news. One could spend a pile of money by sending the drive to a professional recovery service to see if they can recover the data on the drive.

If one has been using the Backup (Safepoint) feature of the My Cloud Dashboard then one will still have access to their data as of the last Backup/Safepoint.

Thank you both for trying to help. To clarify this more:
I had the same problem before and I was able to remove the PCB from a new MyCloud device that I bought and use it to replace the PCB in the first MyCloud I originally bought. The PCB of 2nd device unit had same model number but it was Rev.03 rather than Rev.02, it worked like a charm for a year although Rev. number wasn’t an exact match. I attached pics for both, I now have two hard drivers that work and two PCBs that don’t… I dont really know whats wrong with them and if they can be fixed. I also understand that I cant pull the data out of the hard drive without the PCB … is this correct or is there a workaround?

yep. and the only possible ‘workaround’ would be a platter swap in a clean room environment into a donor hard drive usually reserved for data recovery specialists.

sorry to hear your bad luck with hard drives, personally … i’ve had hard drives fail over the years, which i why i backup all my data onto a 2nd hard drive (and 3rd hard drive for data i really don’t want to lose).

sure, it’s pricey having 3x 4TB hard drives with all the same data on the them … but it’s a lot less expensive than having to use a data recovery service to attempt to recover my data.

That’s NOT correct. The faulty board you have pictured is the MyCloud NAS controller board. It is NOT the HDD controller board.

Read the thread Bennor posted: connect the HDD to a Linux machine, or a PC running an ExtFS driver.

1 Like

If it is a NAS, pull the HDD out and connect it to your PC desktop through SATA port. Then use https://www.howtogeek.com/112888/3-ways-to-access-your-linux-partitions-from-windows/
to read the data on the HDD.

If it is DAS unit which connect through USB port then just buy another cheap unit and swap the hard drive to read the data out of it.

Those pictures appear to be the My Cloud motherboard/backplane not the PCB board on the hard drive itself. Just attach the hard drive to a computer running Linux OR to a Windows PC running a Linux driver and you should be able to pull the files/data off the My Cloud Hard drive.

Here is the backplane of my first gen My Cloud when I was putting an 8TB drive in it. The board the screw driver is resting on is the motherboard/backplane for the My Cloud, it contains the SATA port the hard drive is plugged into.

This is really valuable information, i didnt notice that there are two boards , the motherboard and the Power Control Board. All what I know that since my problem has to do with the device is not connecting to wifi then the hard drive should be OK and the problem is with the board that allows it to connect… so now I understand that my issue is with the motherboard not the PCB. I will start searching for someone who has a linux machine and who can extract the data … thanks you all so much

Wait, what? The My Cloud does not have WiFi. The My Cloud is generally designed to be connected to a network router or network switch using an Ethernet cable. Many consumer level routers include WiFi capability and that is how WiFi clients access the My Cloud. Check the WiFi router the My Cloud is connected to, to ensure the router isn’t blocking access between the WiFi clients and the LAN network. Sometimes this is called IP isolation or WiFi isolation.

You can run a Linux Live CD/USB flash drive on a Windows computer to boot that computer into Linux. Ubuntu is one such popular Live CD program.

it used to connect but then stopped, no blue light, red instead , it was a while back but i verified at the time its not my router , it was the cloud itself that had teh problem

Buenas noches, una consulta…de que capacidad era su dispositivo antes de realizar el cambio por el disco de 8TB. Si fue una capacidad menor (4TB)…podria compartir el procedimiento que utilizo para colocar el de 8TB?
Muchas gracias

If you want to replace the single bay/single drive My Cloud (not My Cloud Home) hard drive, use the forum search feature (magnifying glass icon top right) and search for “unbrick”. There are plenty of discussions on how to replace the single bay My Cloud hard drive with a larger (or smaller) hard drive.

I have used a number of different hard drives in a single bay first generation My Cloud. From 250GB hard drives up to 12GB. I’ve even used 2.5 inch laptop style HDD in the single bay My Cloud enclosure. Some posts I’ve made over the years on using different hard drives in a first gen single bay My Cloud:

Generally most people will use the old Fox_exe user’s directions for unbricking. That person’s files have been archived by someone else to another repository location for access.

Repository: https://wd.hides.su/fox_exe/

First gen directions: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Original_v03.04.01-230.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
Original_v04.01.02-417.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz

Second gen directions: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/_Unbricking_en.txt
usbrecovery.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate way second gen files:
uImage-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery