What the heck it this 'SSH' stuff everyone says (but never EVER, EXPLAINS!...)

I did find this (frm the least nderstanding guy of all, he finally decided to type a step instead of an insult!: I hadn’t noticed it through the trees of insults and silliness: he said this:
Turn on SSH

  1. Download Putty to your computer
  2. Connect to your My Cloud via SSH (you need ur My Clouds IP address to use as host) use welc0me as password
  3. type in sh /etc/rc2.d/S20restsdk-serverd stop and press enter… this will stop the script :)… will it help you? who knows… will it cure your ignorance? definietly not…

Seems like even this is vastly simplified,

There is no listed info for HOW to ‘connect to mycloud (everyone seems to think I will load my first ‘telnet server’ ever and know Just what to do,…) I am SURE I will have to come back here to ask "where do I type all this stuff in?’ I may as well ask now,…

Before doing all this I would maybe think about calling WD and tell them I have found the only way to get my drive to sleep, is to VOID my Warranty on their FORUM and either get their OK to go ahead, or a replacement NON Network internal or external 4TB drive that WILL go to sleep… :wink: I really like to understand EVERYTHING before I go ahead, thats part of the problem :slight_smile:

1 Like

mIRC for Internet Relay Chat(IRC) Putty is more like a telnet client but more secure since it connects over a encrypted connection. Yes I can see how they would not be much help to some one new. They are mostly written by people that know what they are talking about but don’t keep in mind not everyone can simply follow them if they haven’t done things like it in the past.

1 Like

I can help fill in the blanks but yes that was the reply I saw and was talking about. Also no problem about waiting

1 Like

Well, cool - I think I can muddle though now, Even there he had to give a dig and call me IGNORANT (for not knowing a specific technical thing I have never needed,…? WHatever,. I bet he can’t make entire animated worlds for endless film, t.v and video game projects over a 25 year career :slight_smile:

Can I assume it will be obvious HOW to connect to my Cloud? IT will have CONNECT Button? or some such thing? ALSO, Did it also say that I have to do this thing every time the drive turns off and ON? ) As it is, not touching anything, I see it restarts every 10 minutes or so on its own, constantly,… If have to do this every time it restarts, it will be another constant headache, I am SO hoping you will say it is a one time fix :slight_smile:

The button will say open instead of connect the website I posted with the picture shows how its laid out first it opens up to your connection options then once you click open it will take you to a screen that looks like a command prompt

1 Like

No matter how this turns out, you’re a nice guy! Thanks,

Welcome and no problem. I just seen you say it’s restarting every ten minutes? That is not normal and may need a RMA/Call to WD. The SSH into will only help keep it from running its scans. Something that slows it down. It should also help with it not going to sleep when its not being used. I think these save after a reboot but can’t say 100% cause I do not remember I am sure others can answer that tho.

1 Like

I think I am going to give tech another call on Monday, I called last week and said all the problems i was finding listed here (that I had noticed myself), they completely discounted all that and linked to my machine said I have the newest firmware and that everything should be fine, said to TOGGLE the sleep on and off a few times,… Not much help really… Said to call Monday if the drive didn’t sleep by then, they would RMA,… BUT I just know the next one will do the same exact thing.,. Things either work or they don’t in my experience and this doesn’t seem to really work WELL for ANYONE, even the fixes are not really fixes,… Like Kingston for Memory, I have ONLY bought WD hard Drives for decades, to have a favorite company release something so illogical,… it’s dis-heartening! I have loaded Putty,. but I just can’t bring myself to void the warranty, …

Hey it occurs to me, that since I really only need this for archive safety backup, I really could just shut it down, ONLY turning it on to actually save new stuff, or get something back off it, I guess I could have it OFF most of the time.,. That would make both problems almost a a non- issue (the restarting is a WD Access Icon thing, it does NOT seems to affect File Explorer access or copying!! :slight_smile: It just disappears the WD BLue Access icon (in the tray) It reloads (or I reload it from All Program Files ) and says that often,… Now that I hav turned off what I need perhaps I do not really need the ACCESS icon, I just need explorer access then turn it off, Somewhat of a solution, better than letting it kill itself.

WHOA peaked at 143 mb/s copying now with everything turned off… !
Happy New Year!

Happy new year lol. The drive not sleeping is a know problem and changing that switch on and off will not help. Just make sure it’s on. If your drive is resetting itself that sounds like there might be a hardware problem and you might need to get them to replacement. If your just running the commands to stop services running it shouldn’t void the warranty you can also double check if you call. I know they didn’t say mine was and I was able to get a replacement with no problem.

Awesome, I thought that’s what you meant earlier, that helps to know… Thanks…
No I meant when I am not actually copying to the drive, (say, overnight) I will go into the panel and say SHUT DOWN only actually powering it up to copy new backup file then turn all the way off again,… Maybe I will get lucky and it will fall asleep now that I have stopped adding many small files and turned off so much… If not I will jist turn it off when not neded, (won’t hurt it as long as I use the proper shutdown procedurre right? I’m not just pulling the plug out :slight_smile:

What is the longest you have left it on so far? It can easily take a week after whatever is copied to it is done before if finishes its scans and calms down lol.

That might be the best single suggestion yet,… especially after copying a lot to it today, I will give it a good long while to try to scan and settle,… I guess since its a strong NAS I have longer than usual before it would start to degrade from the constant ‘use’ . I will just keep a fan on it to keep it cool,… OK, I will give it a good week or so to do its housekeeping! Good idea,… Especially as i have made so many good changes to the setup today,… (turned off everything I didn’t need,…)

Mega THANKS! Good idea… With a 2017-2018 date of warranty, I have some wiggle room there too LOL…

1 Like

Yeah mine run ok for years without problems even not sleeping most of that time. I just just had other issues that couldn’t be solved / problems with the dashboard. I think problems just had to do with the firmware and with the CPU being to slow in it. Seemed to get worse with the newer firmware.


I don’t think I have seen so much time wasted like this n a thread in a very long time.

I.suggest the OP back off his quest for a crash course in SSH, because he doesn’t need to know it and is driving himself and others here a bit crazy, Instead, he ought to give WD Support a phone call, and ask to be transferred to their Level 2 Support and discuss his issue with them. He has paid for this kind of support.

Although I am a fairly technical and savvy guy in a lot of this techno-babble and associated gear, but I don’t know SSHt about SSH, nor do I ever care to or need to. If I cannot get my gear to work based on basic knowledge in the user manual and my experience, or some questions posed here, then the thing is too complex for the average person (or has an issue). That’s when WD support is going to help me – if they can.

1 Like

Bravo!! I certainly agree. I certainly have no interest in that SSHt! I have plenty of my own technical specialties to fill my time… Thank goodness for the few that were willing to help though. The good news, after turning off Everything possible that makes this a cloud (lol) and not just a network drive, I noticed as I myself lay down to sleep THAT THE DRIVE FINALLY was Sleeping! The light slowly (and comfortingly) is cycling on and off, I also deleted the users (save the one on the actual local machine) and all the other non local access things… Local Network is fine by me, (my Phone company will be happy…)

It would be nice though if it
a) worked right out of the box (or as a CLOUD as advertised…)
b) ‘help’ didn’t come with accusations of being ignorant just because I have had other things to do than learn that SSHt (lol did you come up with that its great!) and the emotional reactions, I’m allowed to complain and be frustrated after all,
oh time for a Star Trek Quote:
“I’ll complain if I want to, it’s comforting” -‘The Doctor’ to ‘7of 9’ on Star Trek Voyager

Also the drive really should be more consistent, by all rights from what I learned here today, and after spending ALL day copying ~2 TB to the drive, it SHOULD be but is NOT doing this extended ‘thrashing scan’ or whatever is plaguing so many others, I wonder if they deleted all but the ‘users’ on the local machine it might help (I have no idea what of the many things i turned off did the trick) The drive went to sleep pretty much as soon as my computer did! Pretty much 100% proof you are correct that the drive does NOT need crazy low-level SSH editing (or whatever SSH was supposed to do to it)…
My computer by the way is a DELL T7910 Workstation 36 core/72 threads and 512GB DDR4 running win7 64 bit) Thanks for your support and logical summary! Happy New Year

IT WENT TO SLEEP!!! I set my computer to sleep for the night, I looked up a while later to be certain it had done so, (the computer I mean which gives a bright white flashing light) and noticed a slowly blinking blue light on the cloud! I realized, ITS WORKING! It has only done this once before on day one… I did delete the cloud Users I had (my roomate) on it along with turning off all the stuff we discussed, Its funny because I spent the day copying my MARS 3D Bluray project (many BIG Stereoscopic Raw Satellite Files) and it was about ~2 TB of data, but it does NOT seem to be running hot or doing any of that data crunching, and it SLEPT! It’s SO weird, I Figure if one TURNS OFF all that No Server Stuff BEFORE copying the bulk of data onto the drive, perhaps it does not worry about doing all those thumbnails or whatever it is doing on others drives,. I’m getting peaks of 143 Mb/s and it went to sleep along with my computer, waking up with it when I jumped out of bed and woke it to type this! I guess my problem is finally fixed and without all the SSH’y stuff (Mayan Codexes! :slight_smile: LOL I do greatly appreciate your (and the other gracious ppls’ ) help, somewhere along the line that was what made the difference, another big thing is my IP must have changed along the way, and that is the source of the initial frustration, as the BOOKMARK the tech guy made for my Internet Explorer was no longer working and driving me crazy (that’s the only way I knew to get to the ‘dashboard’ because in the WD taskbar thing, it is called ‘SETTINGS’ but opens what is called the ‘Dashboard’ !! so I had people telling me to find things that were not listed ANYWHERE! LOL Anyways it seems to have worked out really well ,. It had a explorer window open when i woke up computer, it woke the drive up, I closed the window when I started to type here, just looked down (almost jokingly) to check, it has gone BACK TO SLEEP! Good drive :slight_smile:

You should be able to bookmark http://wdmycloud instead and not need to worry about the ip changing you could also set it up to use a static ip so that it doesn’t change on you. Glade its all working for you now.

This might help Robert understand the process.