Whare are the OS5 SDK tools?

I would like to have a crack and writing my own app for the OS5 NASs.

Where do I point my web browser to get what I need?

I don’t know if it helps, but in the firmware page you can download the source code of their OS.
That’s a great initiative!! We can only rely on people like you to make their products better since they don’t care about their users as Synology does.

You can check out this page - Home

OS5 app is similar to OS3. Mainly a difference of packager.

@jchen, thanks for the reply, but the information you have given me is not working. I’ve registered for the Developer account, but your web site appears to be quite broken.

Does matter what I do, I’m taken in a circle and landed on this page.

The download link to get the remainder of the SDK does the same.
I’m even trying this in a private browsing window so it’s not a browser cookie relates issue.

Can you help me with this?

@jchen can you send me the version of mksapkg that also supports the DL4100? You sent this one …

root@ZEUS home # ./MyCloudOS5_mksapkg
ERROR: model_name not specify

Usage: mksapkg -E -s -m [model_name]

Supported model_name:

root@ZEUS home #

@SBrown , could you help me with this?

@Myron My Cloud OS 5 SDK

Thank-you @SBrown :slight_smile:
One more question, for the DL4100 which model_name value do I use?

@Myron a new package has been uploaded which supports the DL2100/DL4100

@SBrown , have sent you a private message. The Devs web site having me chase my own tail. Explained in msg I’ve sent.

@Myron if you don’t mind, what are you planning on develop?

First thing I want to try is get SoftEther VPN working as an installed application as opposed to having to install Entware to then be able to use SoftEther VPN.

I am also stuck on the WD Developer page and I can not get to any downloads for the off-device SDK. Is the page just broken or am I missing something?

I’d like to package a simple application which I run on my EX2 Ultra. I tried copying the files that the plex app brings, but now I am at the point where I want to package everything and install my app via the admin UI.