Web Interface dashboard not available

Having some problems getting to the dashboard on my Mycloudmirror.

TwonkyMedia works (port 9000)

Transmission works (port9092)

SMB works, I can access all my files.

SSH works

I just can’t get the web dashboard to display.  In Chrome it comes up with  “This web page is not available ERR_CONNECTION_RESET”

I have tried a reset using the button on the rear, that didn’t fix things.

I have tried reloading the firmware from SSH (using updateFirmwareFromFile.sh - flashing the downloaded and unzipped firmware).   After successfully flashing and restarting, it’s made no difference.

Run out of ideas on what to do next.   Is there some way to reset the device WITHOUT losing my data?

Well, gone backwards…

found a factoryrestore.sh  that took a noreformat  argument

Ran that, it did some stuff, rebooted, can still access SMB and my files are still there, but still no web UI access, and no SSH either now :frowning:

Suggestions on how to get this back to factory condition without data loss?

Got to the bottom of things, it wasn’t the MyCloud, it was my new Linksys router doing silly things.  A factory reset of the router and now I can access ALL the Mycloud services, not just some of them…

Not sure what was going on, it’s as if the router was blocking port 80 requests.  There was definately something weird going on, as in the device survey, I had a couple of LIFX wifi bulbs that had a devicename of WDMYCLOUDMIRROR, which was clearly wrong…

Anyway, it’s all back up and running, factory reset, and I need to make my shares private, but all the data is still there.

Hmm, after a week, mycloud isn’t accessible on web interface again. This time, my finger is pointing firmly at my Linksys router…


Does your router have firewall setting? If yes, check the option on the router to see if that is not allowing you to connect properly. 

Also have you tried reaching out to WD Support? 

WD Contact info:


No, it’s some weird bug in the Linksys router.   Have thrown the cr@p in the bin and gone back to my Billion router, it’s been fine ever since.

When this issue occurs - you can cable your computer directly to the NAS. If you can bring upthe interface then it is the router.

Make sure your router and NAS are on the same subnet - and give your NAS a fixed IP address on the subnet if it is occuring every few days. 

OK, this is now starting to annoy me. I have a new router (Amazon give me lots to review!), Another linksys, this time a WRT1900ACS, and it’s doing exactly the same again, unable to access port 80.

I appreciate it’s not a problem with the Western Digital, but Linksys support is so rubbish, I don’t get much help from them. Anyone got any practical suggestions as to why I never have a problem with the Mycloud with any brand of router, but when I use a Linksys, it’s nothing but trouble,…