WDTV live maybe dead, help!


#1

Hi there,

first post in here, I am in need of some help:)

My WDTV Live less that a year old, looks like dead right now. Yesterday I upgraded the firmware to the latest beta (1.03.38V) and all was fine, but today as soon as i switch it on, only the initial WDTV Live welcomscreen cames up,

it then just turns black screen. I have tried it to reset it, start with a usb stick with a different fw, but its still the same…it starts, welcome screen then black, altrough the light on the actual player is still on and i can switch it off or on via remote.

Is there something ealse I could try, or is it just to RMA it?

Thanks in advance


#2

Welcome to the forums.

Reset it but then unplug it from power for at least 10 minutes (longer is better).  Then try again.


#3

Hi, and thanks for the tip, but after 20+min that didnt work :frowning:


#4

Did you try turning it on without a drive attached?


#5

Well, I never really have anithing attached to it as I stream from my PC via LAN, the only time I attach something is when I update the f/w via USB.


#6

Ah, I got you.

It sounds like an RMA is the way to go (although just for fun you should leave it unplugged overnight and try one more time – can’t hurt since it’s too late in the day to return it and tomorrow is Sunday).


#7

It also occurs to me it might be an HDMI handshaking issue – if you are connected via HDMI make sure you try the component/composite cable just for grins and chuckles.


#8

I actually just tried that, but no go :frowning:

Thanks anyway


#9

Did you try unplugging / re-plugging the HDMI while the unit was on?

When you attempted a firmware re-flash, what firmware version did you try (and from where)?


#10

Well, I left the unit unplugged overnight, then when I turned it on, it was still not working. This was via HDMI. But

I wanted to give one last try, so i plugged it via composite and…IT WORKED!! Reattached the HDMI cable, and that was

also working again, finally, took the component cable off, and after few tries, it seems to work as normal. Really strange though… It does soung firmware related, it has worked great for several months, it did this just after the latest beta.