New update killed my WD TV Live


#1

Yes, I have to blame it on this new firmware. I’ve owned my box for several months now. I’ve taken updates, experienced problems and rolled back quite a few. Now after taking this update, during the install the video never came back. I’ve done everything I could. Now the unit is off  and unplugged and I’m waiting. I don’t know what I’m waiting for but it really ■■■■■.

Is anyone in the same situation? Has anyone experienced this before and fixed it?

Problem: Unit turns on, finds and scans drive if I have one connected and then just stays on showing a blank screen. What about this “auto sense” of where to output the video? Is that working in this release? Yeah, ■■■■■ big time. Dammit.


#2

do you have any other output sources you can try it on like HDMI vs. Component or maybe try some upnp remote to see if you can get some life that way ?


#3

Have you tried resetting via the side button with the unit on. Use the composite cable to test. Most people have a video in on a video or something like that. Even TV’s with HDMI are likely to have a composite input.


#4

I’ll be trying some stuff tonight and I’ll let you know. I use composite already. I did the reset, disconnect the power thing and all - nothing. I have the older firmware ready on a usb drive so all I want to do is roll it back. Can’t do that wothout video output at least. I have a suspicion that it’s not autodetecting the output. Once I feel like moving some stuff around, I’ll try different outputs and let you guys know how it turns out. Thanks for your responses. Any other ideas, I’m open for them. I don’t plan on letting it become a doorstop. Should be able to get around this issue somehow. 


#5

I don’t think this is likely to be touted as a solution but…after several restarts, a picture showed up on composite but was rolling pretty fast and could not easily be read. After a few shots in the dark, I managed to rollback to software on my usb. Then reset everything including sending output to component, which I use on my rear projection big screen. It’s back up and running but I don’t think I’ll be taking software updates. That’s a shame. I did surf around enough to find a few unofficial WDTV firmware sites that I just bookmarked for now. Better to leave well enough alone but I’m very, very reluctant to take official releases anymore. At least not until I feel like troubleshooting software for free. :dizzy_face:


#6

I updated to verson 1.02.21 and the WD TV Live can NOT access my server File Shares any more, worked ok before. I have reentered the log on info and the registration info and still no good. It will access the server if I turn the Media Server option on on the servers (BUT WHERE IS THE SECURITY THERE), I dont use Media Server. All I get from trying to access my servers is “The network share can not be accessed”! I didn’t care for my Netgear media server and gave it away so I got the WD Live and now I dont like it either…