WDTV Live firmware update - warning!


#1

I just want to let folks know about a firmware update problem I experienced.  Perhaps someone from WD can comment on this problem and if it will be addressed?

I purchased a WDTV Live unit a few weeks ago. The unit has been working great up until a few nighs ago. When turning it on, it said there is a new firmware update available (version 1.01.11) which i selected to install. The unit obviously checks over the Internet for new firmware.  After the installation finished and the unit restarted, it displayed a screen stating “Insert a USB drive with firmware to recover your WDTV”. I tried pressing the small reset button and also downloaded the v1.01.11 firmware and copied to a USB drive but the unit continued to display the same screen on powerup.

I emailed WD tech support and they said the unit was unrecoverable and to send it in RMA for a replacement.  I certainly hope this same nightmare doesn’t happen with the replacement!

-AJ


#2

Hi, seems that my troubles came with latest firmware too:

http://community.wdc.com/t5/forums/forumtopicpage/board-id/tv_live/thread-id/7

I got an answer from WD support about replacement and just waiting it from the shop where I’ve purchased.

Looks not so optimistic so far (still there are negative feelings from my WD MyBook WE)


#3

How fast is your internet? It has been suggested that if it takes more than 5 mins, the device goes to sleep or something.


#4

I had similar troubles: the WD TV Live offered to update itself. I accepted and it downloaded the firmware upgrade and rebooted once. Then it would hang at 0%. After about 25min, I tried the reset button, which did do nothing. So I simply pulled the power plug and re-inserted it after 20s. A grey screen appeared, asking me to insert a USB-Key with a firmware.

I worried and searched for a USB-Key, which I do not own. After begging my wife to allow me to use her USB-Key, backing up all its data, and loading the newest firmware onto the key, I returned to the living room, where the WD TV Live had meanwhile already recovered entirely on its own. I checked and the firmware version was the neweset. No problems with using it either. I returned the unused USB-Key to my wife.


#5

When I get my RMA replacement, I won’t install firmware updates via Internet - just by USB key.  Hopefully that will prevent further upgrade problems.

-AJ


#6

They have just released a new firmware version, a critical update which fixes something in the update manager.

Perhaps that is a fix to your problem


#7

indeed, and now my wd tv live is a brick. It prompted me with a new FW version to install and I agreed. The progress bar went to 100% downloading the new FW. Then a message indicating, that the device will reset itself appeared. After the reset I saw only the WD logo on a blue background. Nothing happened after this. Perhaps after half an hour I disconnected the device from power. Now it shows only the black screen prompting me for a USB drive with a firmware. Unfortunately this does not work. I connected a USB Stick (16GB / fat32) with the extracted firmware (3 files) and after some LED blinks on the USB stick nothing happens! Before the update, the device had the 1.01.11 fw release installed.


#8

AUGH I did the same thing.

now what?

edit: Just a question for everyone in this forum, did anyone of you have b-rad’s firmware on your wdtv and then do this firmware update?


#9

Exactly the samen here! I am so furious. I have waited months for this device, now I have had it for two (!) days and it appears to be broken.

I downloaded the supposedly ‘critical’ update - that would repair something that wasn’t broken - and now my device is ruïned. Reading the same story from Ignite and others, I can’t hold myself or my ignorance responsible. While I am typing this, the WD Live is still asking for firmware which I just inserted on my usb. This could mean thousands of broken WD TV Live’s if WD cannot fix it from distance. I hope I can switch my device for a new one.

I now know never to trust WD’s updates again. Thank you for ruïning my trust in an otherwise perfect device.

A very pissed of egschaafsma


#10

Same problem here.  My unit is only 2 days old and the day I got it I did a firmware update.  Today it told me there’s another update and when I installed it the unit hung on the blue “WD” screen.  I waited 30 minutes with no change, pulled the plug, and now I’m getting the “Insert a USB drive with firmware to recover your WDTV” message.  I tried downloading the firmware onto both a 4GB and an 8GB drive and this message stays the same.  Any advice before I return my unit as DOA?


#11

Yup, same with mine, dead.  I have never had home brew firmware installed.


#12

Ditto here, bricked


#13

Same problem here :cry: Mine is only 4 days old.


#14

Check out the discussion at  http://wdtvhd.com/index.php?showtopic=9399  


#15

Oh dear, feel sad for your guys.

When it prompted me to upgrade I took the chance, and it went fine, took about 2 minutes i think.

Its ironic if this was the bug they tried to fix, but it cause problems for some people instead.


#16

i got mine yesterday - when i connected it, it updated itself to (version 1.01.11)  -EVERYTHING worked fine, I was amazed…

…Short lived, tonight it sad it had a new version (version 1.01.12), trusting the wd support i let it do an update, downloaded, restarted - and stopped at WD screen for half an hour, pulled the plug out - now it hangs on te stupid screen telling me to put a USB device in - tried 4 or 5 usbd drives - it does’t work - tried fat, fat32, ntfs

---------- BRICKED ------------ my Wii never did that… :frowning:

so WD - do something ??? i had mine for a one DAY, [text deleted]  ONE DAY !!!


#17

I wish I had visited the forum before I said yes to the upgrade - my is frozen on the connect USB drive screen as well - tried all the same things - reformatted USB key, downloaded firmware 1.01.12, plug it in and no go.  Oh well, I’m not alone and I enjoyed my 24hrs of use (abuse).


#18

Hello - Just **bleep**.  Is there no solution?


#19

Tried evey piece of hardvare i had - even my 2TB WD book drive, tried changing vesions… nothing, zilch, nana, njente, 0

Still bricked !@(**&$#@


#20

Well what can I say… apparently nothing new since this is happening to almost EVERYONE. I have an AppleTV and was very happy with it using XBMC, but it has one fatal flaw - it doesn’t play HD very well at all.  If I wanted to stick with SD files I would be fine, but with a 50" plasma, I just couldn’t settle.  Besides, I was getting tired of having to noodle around with patches and so forth and thought I would just buy something that handles it all right out of the box.  So I figured forget patches and hacks and get something that just works out of the box, with no hassles.

The day I bought my WDTV Live (less than a week ago) I plugged it in and it immediately detected a new firmware update.  I ran it and it rebooted fine.  It was a bit slower than I had hoped but that’s not a big deal. 

Today, after a fairly busy day at work I was really looking forward to getting home and watching my videos to wind down after a stressful day.  Feeling happy that I wouldn’t have to mess around with conversions etc. to watch a nice HD stream, I sat down and turned on the WDTV. 

POP!  Another firmware update!  GREAT! I thought! Looks like WD is really responsive with their product, and are rolling out updates fairly consistently.  It seemed pretty encouraging, since although the WDTV Live HD plays HD very well, it’s rather lean on the usability features (despite the clean interface) and I was looking forward to putting in some feature requests that would hopefully be implemented.

For example, it would be handy to be able to skip ahead by 30 seconds etc.  Another nice feature would be to be able to change the volume with up and down.  My TV volume doesn’t control the stream passing through, so I have to get up and adjust my sound system. I also thought it was kind of dumb to have a file manager that couldn’t move files between two different sources - what’s the point if you’re just moving a file around in the same directory?  Most people want to be able to transfer files from a SOURCE to a DESTINATION!!  (XBMC has a lot of great usability features by the way)

Lest I digress, I’ll get back to the point (which really should be how great the show I WANTED to watch was, but I guess that will have to wait).  In confidence and optimism I immediately fired up the firmware update.  I patiently waited while it downloaded and did it’s slow install, figuring it would be worth it and then get on with my show.  I went to check my email and came back to the blue screen with the WD logo on it, frozen.

The remote was unresponsive and it just sat there about a half an hour.  I remembered last time it took a while, so I waited a bit longer, but finally after about 40 minutes I gave up, and cycled the power, hoping that it was just a reboot cycle issue and that turning it off would resolve it.  NOPE!

So now I have this nice multilingual screen that tells me to insert a USB drive with firmware to recover the device.  I download the firmware and put it on 4 different USB drives.  Tried reformatting them all using FAT32 and still nothing.  Sure, the USB drive’s light blinks and such for a moment but then nothing.  I have no idea if this means it’s actually running invisibly in the background, or it’s just sniffed at it and walked away. 

I tried calling WD support, but apparently they don’t like to be in the office when people are at home watching their media - in the evening.  I guess we are supposed to call in from work during the day when we aren’t in front of our TV and magically fix it while away from the house?!?  There should be a 24 hour support line, or at least something until say, 11pm for us regular “day walker” people who have day jobs to pay for these products that we use when we are AT HOME AFTER WORK HOURS.

it’s now been a good 3 hours of goofing around with this thing and all I have to show for it is a strong desire to restock this thing and buy the ASUS O!Play, which just happens to be on sale for $40 less than I paid for this device, more than enough savings to cover my restocking fee, which I will probably be able to get them to waive, since as far as I’m concerned this is a DEFECTIVE PRODUCT.

Now in WD’s defence, I can say that they couldn’t know that this would happen to so many people, but it shows a lack of testing, and in any case, their site should have a firmware restore kit easily found on their site.  There is plenty of info on how to install a WORKING firmware update on a WORKING WDTV Live, but ZERO on how to RECOVER a bricked one, which might be a an entirely difference process.  There should be a nice big fat download right there with the whole shebang, maybe even an ISO or a utility to properly format the stick itself and put the recovery files on it for you. 

How’s this for an idea: with each WDTV Live sold, they should include a locked USB stick that will recover a toasted machine to factory defaults regardless of what happened.  Then if something goes wrong, at least the user isn’t screwed or feeling burned.

So as far as I’m concerned WD, you have until I get home from work tomorrow to deliver a working solution that doesn’t require me to RMA your product.  If I have to send it back anywhere, it will be to the store where I bought it, and I will come home the SAME DAY with a WORKING PRODUCT, rather than wait X days for something that will MAYBE work ok once again. 

Honestly WD, I am genuinely rooting for you to deliver, otherwise I wouldn’t have bought your product, but I have to say I’m not too impressed with this experience at all.